A1058 A+B in Hogwarts (钱币转换)
If you are a fan of Harry Potter, you would know the world of magic has its own currency system – as Hagrid explained it to Harry, “Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it’s easy enough.” Your job is to write a program to compute A+B where A and B are given in the standard form of Galleon.Sickle.Knut
(Galleon
is an integer in [0,107], Sickle
is an integer in [0, 17), and Knut
is an integer in [0, 29)).
Input Specification:
Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.
Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input.
Sample Input:
3.2.1 10.16.27
结尾无空行
Sample Output:
14.1.28
题意:
输入两个Galleon.Sickle.Knut
货币的值,将值相加,输出结果。
分析:
这道题说实话并不难,可我不愧为踩坑小能手,相信很多人这个题目没有拿到满分都是第二个测试点没有通过的吧,大家的问题应该是没有考虑到数值的溢出吧,所以把int改成long long 类型的就行了,但是我!哎,我是错在了c>=29和b>=17,我错在没有写这个等于号,题目中是不包含,改了之后成功AC!
易错点:数值溢出&数值范围
代码如下:
#include<cstdio>
int main(){
long long a,b,c,d,e,f;//注意!
scanf("%lld.%lld.%lld %lld.%lld.%lld",&a,&b,&c,&d,&e,&f);
a+=d;
b+=e;
c+=f;
if(c>=29){//注意!
c%=29;
b++;
}
if(b>=17){
b%=17;
a++;
}
printf("%lld.%lld.%lld",a,b,c);
return 0;
}