(2)O - Number Sequence

A single positive integer i is given. Write a program to find the digit located in the position i in the sequence of number groups S1S2...Sk. Each group Sk consists of a sequence of positive integer numbers ranging from 1 to k, written one after another.
For example, the first 80 digits of the sequence are as follows:
11212312341234512345612345671234567812345678912345678910123456789101112345678910
Input
The first line of the input file contains a single integer t (1 ≤ t ≤ 10), the number of test cases, followed by one line for each test case. The line for a test case contains the single integer i (1 ≤ i ≤ 2147483647)
Output
There should be one output line per test case containing the digit located in the position i.
Sample Input
2
8
3
Sample Output
2
2

题意:给出一串特殊的数字,输入t表示有多少组数据,在输入i,输出该数第i位为什么,i超大所以该数只能用数组存储,又因为其规律为1,12,123,1234,12345,所以其规律作为一个单位,用一个数组存储每个单位有几位,再用一个存储当前单位总共几位。不过有些地方不太理解
#include<iostream>
#include<cstdio>
#include<math.h>
using namespace std;
unsigned int num[31270],sum[31270];
void sequence();
int judge(int a);
int main()
{
 int t,n;
 sequence();
 cin>>t;
 while(t--)
 {
  cin>>n;
  cout<<judge(n)<<endl;
 }
}
void sequence()
{
 int i,j,k;
 num[1]=1,sum[1]=1;
 for(i=2;i<31270;i++)
 {
  num[i]=num[i-1]+(int)log10((double)i)+1;//到10时,就会有两位,所以log10保证了位数的准确
  sum[i]=sum[i-1]+num[i];//当前总位数
 }
}
int judge(int a)
{
 int i=1,digit,temp;
 while(sum[i]<a)//找在那个区间
 {
  i++;
 }
 digit=a-sum[i-1];
 temp=0;
 for(i=1;temp<digit;i++)
 {
  temp+=(int)log10((double)i)+1;
 }
 return (i-1)/(int)pow(10.0,temp-digit)%10;//不太理解
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值