hdu 1162 Eddy's picture(Prim)

Problem Description

Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input

The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output

Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input

3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output

3.41


题意:给出n个点的坐标,求最小联通距离

题解:最小生成树

注意:数据类型,输出数据格式

#include <iostream>
#include <memory.h>
#include <math.h>
#include <stdio.h>
#define NUM 105
#define INF 0x3f3f3f3f
using namespace std;

double lowc[NUM];
double g[NUM][NUM];
bool vis[NUM];
int n;
struct point
{
    double x,y;
}p[NUM];
double Prim()
{
    double ans=0.0;
    memset(vis,false,sizeof(vis));
    memset(lowc,INF,sizeof(lowc));
    for(int i=1;i<=n;i++)
        lowc[i]=g[1][i];
    vis[1]=true;
    lowc[1]=0;
    for(int i=2;i<=n;i++)
    {
        double Min=INF;
        int k=-1;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&lowc[j]<Min)
            {
                Min=lowc[j];
                k=j;
            }
        }
        if(Min==INF)
            return -1;
        ans+=Min;
        vis[k]=true;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&lowc[j]>g[k][j]&&g[k][j]!=INF)
                lowc[j]=g[k][j];
        }
    }
    return ans;
}

int main()
{
    while(cin>>n)
    {
        for(int i=1;i<=n;i++)
        {
            cin>>p[i].x>>p[i].y;
        }
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=n;j++)
            {
                g[i][j]=sqrt((p[i].x-p[j].x)*(p[i].x-p[j].x)+(p[i].y-p[j].y)*(p[i].y-p[j].y));
            }
        }
        double ans=Prim();
        printf("%.2lf\n",ans);
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值