Win7+Qt5.6.0(64位)+msvc2015编译器 环境配置

根据“Qt简介,Qt 5.6.0-VS2015 版本安装配置图文教程”安装第二套IDE,使用Qt官方的集成开发环境 QtCreator + 微软的WinDbg调试器(内含命令行调试器为CDB)的组合。

安装之后发现Qt 5.6.0(64位)的编译器版本与本机(只安装了VS2008)的编译器版本不匹配,编译程序出现了错误如下:

Error while building/deploying project planets (kit: Desktop Qt 5.6.0 MSVC2015 64bit)When executing step "Make"

查看Qt的配置环境如下:

编译器栏只有如下:


说明安装的Qt 5.6.0(64位)的编译器版本需要64位的C++ Compiler  而本机有的编译器只有32位的(因为没有安装VS2015)。

查阅资料,大部分都说要安装VS2015,由于安装VS2015太慢,太麻烦。查找资料说只要安装“安装MSVC2015,只安装C++”见下文。

在链接 https://www.visualstudio.com/downloads/download-visual-studio-vs  (vs的下载位置)查找了VS2015Visual C++ 库的运行时组件(64位) 和 VS2015的生成工具




下载后先安装VS2015Visual C++ 库的运行时组件(64位); 再安装VS2015的生成工具,(至于是否可以只安装VS2015的生成工具,不安装VS2015Visual C++ 库的运行时组件(64位),不知道是否可行,未测试过!
重启电脑,重新安装Qt5.6(64位),即可,如下图:

    



借鉴于 http://blog.sina.com.cn/s/blog_89a45b020102whg2.html


相关推荐
©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页