UVA 1588 - Kickdown

1588 - Kickdown

Time limit: 3.000 seconds

题目链接:https://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=448&page=show_problem&problem=4463

A research laboratory of a world-leading automobile company has received an order to create a specialtransmission mechanism, which allows for incredibly efficient kickdown — an operation of switching tolower gear. After several months of research engineers found that the most efficient solution requiresspecial gears with teeth and cavities placed non-uniformly. They calculated the optimal flanks of thegears. Now they want to perform some experiments to prove their findings.

The first phase of the experiment is done with planar toothed sections, not round-shaped gears. Asection of length n consists of n units. The unit is either a cavity of height h or a tooth of height 2h.Two sections are required for the experiment: one to emulate master gear (with teeth at the bottom)and one for the driven gear (with teeth at the top).


There is a long stripe of width 3h in the laboratory and its length is enough for cutting two engagedsections together. The sections are irregular but they may still be put together if shifted along eachother.

The stripe is made of an expensive alloy, so the engineers want to use as little of it as possible. Youneed to find the minimal length of the stripe which is enough for cutting both sections simultaneously.

Input

The input file contains several test cases, each of them as described below.

There are two lines in the input, each contains a string to describe a section. The first line describesmaster section (teeth at the bottom) and the second line describes driven section (teeth at the top).Each character in a string represents one section unit — 1 for a cavity and 2 for a tooth. The sectionscan not be flipped or rotated.

Each string is non-empty and its length does not exceed 100.

Output

For each test case, write to the output a line containing a single integer number — the minimal lengthof the stripe required to cut off given sections.

Sample Input

2112112112
2212112
12121212
21212121
2211221122
21212

Sample Output

10
8
15

题目大意就是说,相当于两块木块放入一盒子,求盒子的最短长度,开始WA了好几遍,第二块可以从第一块的左边开始放,同理还可以从右边开始放,两边都计算一下取最小值。


#include <iostream>
#include<cstdio>
#include<cstring>
#define maxn 110
using namespace std;
char str[maxn];
char buf[maxn];
int main()
{
    while(~scanf("%s%s",str,buf))
    {
        int lens=strlen(str);
        int lenb=strlen(buf);
        int cnt_1,cnt_2;
        int i=0,j=0,t=0;
        while(i<lens&&j<lenb)
        {
            if(str[i]-'0'+buf[j]-'0'<=3)
                i++,j++;
            else
                j=0,t++,i=t;
        }
        if(i==lens)
            cnt_1=t+lenb;
        else if(j==lenb)
            cnt_1=lens;
        t=0,i=0,j=0;
        while(i<lenb&&j<lens)
        {
            if(buf[i]-'0'+str[j]-'0'<=3)
                i++,j++;
            else
                t++,j=0,i=t;
        }
        if(i==lenb)
            cnt_2=t+lens;
        else if(j==lens)
            cnt_2=lenb;
        printf("%d\n",cnt_1>cnt_2?cnt_2:cnt_1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值