1006 最短路

                                                        Minimum Transport Cost
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 22 Accepted Submission(s) : 8
Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts:
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.


Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17

Source
Asia 1996, Shanghai (Mainland China)
 
题意:任意两点的最短距离,要求按字典序输出路径 其实就是进行松弛的时候加一个大小判断就行 但是路径的存储还是不熟练~
 
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
#define MAXN 100
const int maxint=65533;
int N;
int distances[MAXN][MAXN];
int map[MAXN][MAXN];//map[a][b]表示a到b的所有路径中的与a最近的一个

int tax[MAXN];
void Floyed()
{
  
    int i,j,k;
    for(i=1;i<=N;i++)
     for(j=1;j<=N;j++)
        map[i][j]=j;
    for( i=1;i<=N;i++)
    {
        for( j=1;j<=N;j++)
          for( k=1;k<=N;k++)
          {
              int t_dis=distances[j][i]+distances[i][k]+tax[i];
              
              if(distances[j][k]>t_dis)
              {
                  distances[j][k]=t_dis;
                  map[j][k]=map[j][i];
                
              }
              if(distances[j][k]==t_dis)//字典序 
                if(map[j][k]>map[j][i])
			map[j][k]=map[j][i];    
          }    
    }    
} 
int main()
{
   
    int i,j,A;
    while(cin>>N)
    {
    	if(N==0) break;
        for(i=1;i<=N;i++)
          for(j=1;j<=N;j++)
          {
              cin>>A;
              if(A==-1)
			   distances[i][j]=maxint;
              else 
			   distances[i][j]=A;
          }
        for(i=1;i<=N;i++)
		 cin>>tax[i];
        Floyed();   
        int a,b;
        while(cin>>a>>b)
        {
            if(a==-1&&b==-1)break;
            cout<<"From "<<a<<" to "<<b<<" :"<<endl;
            cout<<"Path: "<<a;
            int t=a;
            while(t!=b)
            {
                cout<<"-->"<<map[t][b];
                t=map[t][b];
            }    
           
           cout<<endl;
            cout<<"Total cost : "<<distances[a][b]<<endl<<endl;
           
        }     
    }
    return 0;    
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
项目:使用AngularJs编写的简单 益智游戏(附源代码)  这是一个简单的 javascript 项目。这是一个拼图游戏,也包含一个填字游戏。这个游戏玩起来很棒。有两个不同的版本可以玩这个游戏。你也可以玩填字游戏。 关于游戏 这款游戏的玩法很简单。如上所述,它包含拼图和填字游戏。您可以通过移动图像来玩滑动拼图。您还可以选择要在滑动面板中拥有的列数和网格数。 另一个是填字游戏。在这里你只需要找到浏览器左侧提到的那些单词。 要运行此游戏,您需要在系统上安装浏览器。下载并在代码编辑器中打开此项目。然后有一个 index.html 文件可供您修改。在命令提示符中运行该文件,或者您可以直接运行索引文件。使用 Google Chrome 或 FireFox 可获得更好的用户体验。此外,这是一款多人游戏,双方玩家都是人类。 这个游戏包含很多 JavaScript 验证。这个游戏很有趣,如果你能用一点 CSS 修改它,那就更好了。 总的来说,这个项目使用了很多 javascript 和 javascript 库。如果你可以添加一些具有不同颜色选项的级别,那么你一定可以利用其库来提高你的 javascript 技能。 演示: 该项目为国外大神项目,可以作为毕业设计的项目,也可以作为大作业项目,不用担心代码重复,设计重复等,如果需要对项目进行修改,需要具备一定基础知识。 注意:如果装有360等杀毒软件,可能会出现误报的情况,源码本身并无病毒,使用源码时可以关闭360,或者添加信任。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值