hud 4722 Good Numbers(数位 DP)

Problem Description
If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.
 

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
 

Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
 

Sample Input
  
  
2 1 10 1 20
 

Sample Output
  
  
Case #1: 0 Case #2: 1
Hint
The answer maybe very large, we recommend you to use long long instead of int.

 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
#define LL long long

LL digit[30];
LL dp[30][30]; //位数为i时,和为j时满足条件的个数

LL dfs(LL pos, LL pre, bool doing)
{
    if(pos == -1) return pre == 0;
    if(!doing && dp[pos][pre]!=-1)
        return dp[pos][pre];
    LL ans = 0, npre;
    LL end = doing ? digit[pos] : 9;//doing 是否为真为真end=digit[pos]
    for(LL i = 0 ; i <= end ; i ++)
    {
        npre = (pre + i) % 10;
        ans += dfs(pos - 1, npre, doing && (i == end));
    }
    if(!doing) dp[pos][pre] = ans;
    return ans;
}

LL calc(LL x)
{
    LL pos = 0;
    memset(dp, -1,sizeof(dp));
    while(x)
    {
        digit[pos ++]= x % 10;
        x /= 10;
    }
    return dfs(pos - 1, 0, 1);//pos是位数,
}

LL a,b,ans;
int main()
{
    int T;
    scanf("%d",&T);
    for(int ncase = 1; ncase <= T; ncase++)
    {
        scanf("%I64d %I64d",&a,&b);
        ans = calc(b) - calc(a - 1);
        printf("Case #%d: %I64d\n",ncase,ans);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值