lightoj1076 Get the Containers 二分

Description

A conveyor belt has a number of vessels of different capacities each filled to brim with milk. The milk from conveyor belt is to be filled into ‘m’ containers. The constraints are:

  1. Whenever milk from a vessel is poured into a container, the milk in the vessel must be completely poured into that container only. That is milk from same vessel cannot be poured into different containers.
  2. The milk from the vessel must be poured into the container in order which they appear in the conveyor belt. That is, you cannot randomly pick up a vessel from the conveyor belt and fill the container.
  3. The ith container must be filled with milk only from those vessels that appear earlier to those that fill jth container, for all i < j.

Given the number of containers m, you have to fill the containers with milk from all the vessels, without leaving any milk in the vessel. The containers need not necessarily have same capacity. You are given the liberty to assign any possible capacities to them. Your job is to find out the minimal possible capacity of the container which has maximal capacity.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains two integers n (1 ≤ n ≤ 1000), the number of vessels in the conveyor belt and then m (1 ≤ m ≤ 106), which specifies the number of containers to which you have to transfer the milk. The next line contains the capacity c (1 ≤ c ≤ 106) of each vessel in order which they appear in the conveyor belt. Note that, milk is filled to the brim of any vessel. So the capacity of the vessel is equal to the amount of milk in it.

Output

For each case, print the case number and the desired result. See the samples for exact formatting.

Sample Input

2
5 3
1 2 3 4 5
3 2
4 78 9

Sample Output

Case 1: 6
Case 2: 82

Hint

For the first case, the capacities of the three containers be 6, 4 and 5. So, we can pour milk from the first three vessels to the first container and the rest in other two containers. So, the maximum capacity of the container is 6. Suppose the capacities of the containers be 3, 7 and 5. Then we can also pour the milk, however, the maximum capacity is 7. As we want to find the result, where the maximum capacity is as low as possible; the result is 6.

题意

n桶牛奶 装在m个容器里 牛奶装的顺序要从前往后装 (数组位置不能变)
每桶牛奶要倒完 且只能倒在一个容器里 问如何装牛奶使装最多牛奶的容器的有最小容量

题解:

二分查找答案 即最小容量 当不是最小容量时 此时装的容器可能小于m个 说明此值还很大 区间要往左靠 二分区间要选择最大体积的牛奶到所有牛奶之和之间

代码

#include <cstdio>
#include <cmath>
#include <algorithm>
using namespace std;
const int N  = 1e3+100;
int a[N];
int n,m;
bool check(int k){
    int cnt = 1;
    int p = 0;
    for (int i = 0; i < n; ++i){
        if (p+a[i]<=k){
            p+=a[i];
        }else {
            p = a[i];
            cnt++;
        }
    }
    /*某段的数之和越大 说明分的段数越少 说明这个k较大*/
    if (cnt<=m) return true;
    else return false;

}
int main(){
    int t;
    int kase = 1;
    scanf("%d",&t);
    while (t--){
        scanf("%d%d",&n,&m);
        int ans = 0,l = 0;
        for (int i = 0; i < n; ++i){
            scanf("%d",&a[i]);
            ans += a[i];
            l = l>a[i]?l:a[i];
        }
        printf("Case %d: ",kase++);
        int r = ans;
        while (l<=r){
            int mid = (l+r)>>1;
            if (check(mid)) r = mid-1;
            else l = mid+1;
        }
        printf("%d\n",r+1);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值