08-排序5. Sort with Swap(0,*) (25)

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}
Swap(0, 3) => {4, 1, 2, 3, 0}
Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:
10 3 5 7 2 6 4 9 0 8 1
Sample Output:
9

提交代

————————————————————————

嗯,这个题目刚刚开始思路,算法的问题,知道怎么做之后,代码就不难了。

在云课堂的最后一讲里面有。

一个直接的思路是将0和0所在位置应有的元素交换,如果0到达了0号位置但是序列没有完全变成递增序列,则让0和一个没有归位的元素进行一个废交换,然后再进行后续的交换。

一个独特的思路是,将0应在位置的元素(即A[0])换到它应该在的位置(例如A[0]=3,则把A[0]和A[3]交换),不断这样交换,直到0真正到了0位置,判断一下是否全部归位,不然的话就把0换到第一个没有归位的元素上,其实这一步就是上面的废交换,接下来再重复进行上面的交换,直到序列变为递增序列。要注意的是,每次检索第一个没有归位的元素时,起步的值根据A[0]所交换的位置开始,否则会超时。下面的算法用这个思路实现。

#include <iostream>
#include <stdlib.h>

using namespace std;

/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int findfirstnot(int * a, int begin, int end)
{
	for(int i=begin; i<=end; i++)
	{
		if(*(a+i) != i)
		{
			return i;
		}
	}
	return 0;
	
}

void myswap(int *a, int *b)
{
	int tmp=*a;
	*a=*b;
	*b=tmp;
}

int main(int argc, char** argv) {
	int N;
	cin>>N;
	int *a=(int *)malloc((N+1)*sizeof(int));
	for(int i=0; i<N; i++)
	{
		int tmp;
		cin>>tmp;
		*(a+i)=tmp;
	}
	
	int cur=findfirstnot(a,1,N-1);
	int cnt=0;
	while(cur !=0 )
	{
		if(*a == 0)
		{
			myswap(a, a+cur);
			cnt++;
		}
		while(*a != 0)
		{
			int curtoswap=*a;
			myswap(a,a+curtoswap);
			cnt++;
		}
		cur=findfirstnot(a,cur,N-1);
	}
	cout<<cnt<<endl;
	
	return 0;
}





评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值