Strange fuction 2899 (二分+数学求导)

Strange fuction

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4717    Accepted Submission(s): 3383


Problem Description
Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
 

Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
 

Sample Input
  
  
2 100 200
 

Sample Output
  
  
-74.4291 -178.8534
//一个简单的二分题,但得要先判断一下导数的正负来确定函数的输出
//比较简单(一遍AC)
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
double fun(double x)
{
	return 42*x*x*x*x*x*x+48*x*x*x*x*x+21*x*x+10*x;
}
double f(double x,double y)
{
	return 6*x*x*x*x*x*x*x+8*x*x*x*x*x*x+7*x*x*x+5*x*x-y*x;
}
int main()
{
	int t;
	double y;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		if(fun(0)>y)
			printf("0.0000\n");
		else if(fun(100)<y)
			printf("%.4lf\n",f(100.0,y));
		else if(fun(0)<y&&fun(100)>y)
		{
			double l=0,r=100,mid;
			while(r-l>1e-10)
			{
				mid=(l+r)/2;
				if(fun(mid)-y>1e-6)
					r=mid;
				else	
					l=mid;
			}
			printf("%.4lf\n",f(mid,y));
		}
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值