每日一题(2)——Maximum sum

这是一个关于寻找给定序列中连续子数组最大和的编程问题。输入包括一个整数数组,输出要求是这个数组中连续子数组的最大和。示例输入和输出展示了如何处理边界情况和负数。提示部分可能包含解决该问题的算法思路。
摘要由CSDN通过智能技术生成
问题ID POJ2479
Maximum sum
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 28229 Accepted: 8626

Description

Given a set of n integers: A={a1, a2,..., an}, we define a function d(A) as below:
 
 
 
Your task is to calculate d(A).

Input

The input consists of T(<=30) test cases. The number of test cases (T) is given in the first line of the input.
Each test case contains two lines. The first line is an integer n(2<=n<=50000). The second line contains n integers: a1, a2, ..., an. (|ai| <= 10000).There is an empty line after each case.

Output

Print exactly one line for each test case. The line should contain the integer d(A).

Sample Input

1

10
1 -1 2 2 3 -3 4 -4 5 -5

Sample Output

13

Hint

In the sample, we choose {2,2,3,-3,4} and {5}, then we can get the answer.

Huge input,scanf is recommended.
 
 
解答:解这道题我用到了求连续子串最大和的问题(以前写过),分别从不同的位置将原数据划分成两个子串,然后分别求最大连续子串和,然后求和,最后比较输出最大值。(动态规划思想,使用sumCal[100][100]保存中间结果)
 
#include <iostream>

using namespace std;

int data[32];
int sumCal[100][100];
int n;

int calmax(int low,int high)//求连续子串最大和的函数;
{
	if(sumCal[low][high]!=0) return sumCal[low][high];
	
	int maxTohere=0, maxAll=0;
	for(int i=low; i<=high; i++)
	{
		maxTohere += data[i];
		if(maxTohere<0) maxTohere=0;
		if(maxTohere>maxAll) maxAll=maxTohere;
	}
	sumCal[low][high]=maxAll;
	return sumCal[low][high];
}

int divide( int k)
{
	int sum1=0,sum2=0,sum=0;
	sum1=calmax(0,k);
	sum2=calmax(k+1,n-1);
	sum=sum1+sum2;
	return sum;
}

int main()
{
	memset(data,-1,sizeof(data));
	
	cin>>n;
	for(int i=0; i<n; i++) cin>>data[i];
	int max=0, tmp=0;
	for (int j=0; j<n; j++)
	{
		tmp=divide(j);//从不同位置划分成两个子串
		if(tmp>max) max=tmp;
	}
	cout<<max;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值