poj 2312 Battle City(优先队列+bfs)

Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7897 Accepted: 2640

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8

Source

POJ Monthly,鲁小石

http://blog.csdn.net/furturerock/article/details/5568305感觉bfs总结的很不错,这里贴一下链接

题意:和我们小时候玩的一个游戏差不多,需要注意的是遇到B花费的时间和其他地方不一样,需要用优先队列

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int sx,sy,ex,ey,n,m,visit[305][305];
int dis[][2]={
        {0,1},{0,-1},{1,0},{-1,0}
		};//搜索4个方向 
struct node
{
	int x,y,s;
    friend	bool operator<(node a,node b)
    {
    	return a.s>b.s;
	}
  };//由于各点的权值可能不一样,所以这里不能用一般队列,要用优先队列 
  char chess[305][305];
  bool ok(int x,int y)//判断该点是否能走 
  {
  	if(x>=0&&y>=0&&x<m&&y<n&&chess[x][y]!='S'&&chess[x][y]!='R')
  	return true;
  	return false;
  }	 
  int bfs()
  {
  	priority_queue<node>q;
  	memset(visit,-1,sizeof(visit));
  	visit[sx][sy]=0; 
  	node head={sx,sy,0};
  	q.push(head);
  	while(!q.empty())
  	{
  		node f=q.top();
  		q.pop();
  		if(f.x==ex&&f.y==ey)
  		return f.s;
  		for(int i=0;i<4;i++)
  		{
  			int dx=f.x+dis[i][0],dy=f.y+dis[i][1];//对四个方向进行搜索 
  			if(ok(dx,dy)&&visit[dx][dy])
  			{
  				visit[dx][dy]=0;//标记该点是否走过 
  				int temp=0;
  				if(chess[dx][dy]=='B')
  				temp=2;
  				else
  				temp=1;
  				node tmp={dx,dy,f.s+temp};
  				q.push(tmp);
			  }
		  }
	  }
	  return -1;
  }
  int main()
  {
  	while(scanf("%d%d",&m,&n),m+n)
  	{
  		for(int i=0;i<m;i++)
  		{
  			scanf("%s",chess[i]);
  			for(int j=0;j<n;j++)
  	    	{
  		    	if(chess[i][j]=='Y')//起点 
  			    {
  				    sx=i;
  			    	sy=j;
  				    chess[i][j]='S';
			    }
			    else if(chess[i][j]=='T')//终点 
			   {
			  	    ex=i;
			        ey=j;
			    }
		    }
    	}
  		printf("%d\n",bfs());
	   } 
	   return 0;
  }
    


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值