poj 1696 Space Ant 绕圈圈


Space Ant
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4142 Accepted: 2616

Description

The most exciting space discovery occurred at the end of the 20th century. In 1999, scientists traced down an ant-like creature in the planet Y1999 and called it M11. It has only one eye on the left side of its head and just three feet all on the right side of its body and suffers from three walking limitations: 
  1. It can not turn right due to its special body structure. 
  2. It leaves a red path while walking. 
  3. It hates to pass over a previously red colored path, and never does that.

The pictures transmitted by the Discovery space ship depicts that plants in the Y1999 grow in special points on the planet. Analysis of several thousands of the pictures have resulted in discovering a magic coordinate system governing the grow points of the plants. In this coordinate system with x and y axes,  no two plants share the same x or y
An M11 needs to eat exactly one plant in each day to stay alive. When it eats one plant, it remains there for the rest of the day with no move. Next day, it looks for another plant to go there and eat it. If it can not reach any other plant it dies by the end of the day. Notice that it can reach a plant in any distance. 
The problem is to find a path for an M11 to let it live longest. 
Input is a set of (x, y) coordinates of plants. Suppose A with the coordinates (xA, yA) is the plant with the least y-coordinate. M11 starts from point (0,yA) heading towards plant A. Notice that the solution path should not cross itself and all of the turns should be counter-clockwise. Also note that the solution may visit more than two plants located on a same straight line. 

Input

The first line of the input is M, the number of test cases to be solved (1 <= M <= 10). For each test case, the first line is N, the number of plants in that test case (1 <= N <= 50), followed by N lines for each plant data. Each plant data consists of three integers: the first number is the unique plant index (1..N), followed by two positive integers x and y representing the coordinates of the plant. Plants are sorted by the increasing order on their indices in the input file. Suppose that the values of coordinates are at most 100.

Output

Output should have one separate line for the solution of each test case. A solution is the number of plants on the solution path, followed by the indices of visiting plants in the path in the order of their visits.

Sample Input

2
10
1 4 5
2 9 8
3 5 9
4 1 7
5 3 2
6 6 3
7 10 10
8 8 1
9 2 4
10 7 6
14
1 6 11
2 11 9
3 8 7
4 12 8
5 9 20
6 3 2
7 1 6
8 2 13
9 15 1
10 14 17
11 13 19
12 5 18
13 7 3
14 10 16

Sample Output

10 8 7 3 4 9 5 6 2 1 10
14 9 10 11 5 12 8 7 6 13 4 14 1 3 2

Source



题意:给出n个植物(点),从另外一点出发连线段,每次只能左转或者直行,要求线不能交叉,问最多能吃多少植物,并给出行驶路线。


因为出发点的y坐标和植物中最小的y坐标相同。所以n个植物都可以访问。


我的做法就是绕圈圈,听说可以极角排序,但原理都是叉乘。每次选择最外围同时最近的点,然后左转。


                            

#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
using namespace std;

#define all(x) (x).begin(), (x).end()
#define for0(a, n) for (int (a) = 0; (a) < (n); (a)++)
#define for1(a, n) for (int (a) = 1; (a) <= (n); (a)++)
#define mes(a,x,s)  memset(a,x,(s)*sizeof a[0])
#define mem(a,x)  memset(a,x,sizeof a)
#define ysk(x)  (1<<(x))
#define sqr(x)  ((x)*(x))
typedef long long ll;
typedef pair<int, int> pii;
const int INF =0x3f3f3f3f;
const int maxn= 50   ;
const double PI=cos(-1.0);
const double eps=1e-10;
const double inf=1e16;
int n;
bool vis[maxn+10];
int dcmp(double x)
{
    if(fabs(x)<eps)  return 0;
    else return x<0?-1:1;
}
struct Point
{
    double x,y;
    int ind;
    Point(double x=0,double y=0):x(x),y(y) {};
    bool operator ==(const Point B)const {return dcmp(x-B.x)==0&&dcmp(y-B.y)==0;}

    bool operator<(const Point& b)const
    {
        return dcmp(y-b.y)<0|| dcmp(y-b.y)==0 &&dcmp(x-b.x)<0;
    }
}a[maxn+10];
typedef Point Vector;
Vector operator -(Vector A,Vector B) {return Vector(A.x-B.x,A.y-B.y); }


double Cross(Vector A,Vector B)//²æ³Ë
{
    return A.x*B.y-A.y*B.x;
}
double Dot(Vector A,Vector B)//µã³Ë
{
    return A.x*B.x+A.y*B.y;
}
double Length(Vector A)
{
    return sqrt(Dot(A,A));
}

double Angle(Vector A,Vector B)
{
    return acos(Dot(A,B)/Length(A)/Length(B));
}
int st[maxn+10];

double dis(Point A,Point B)
{
    return sqrt(sqr(A.x-B.x)+sqr(A.y-B.y));
}
void solve()
{
    sort(a+1,a+1+n);
    mes(vis,0,n+1);
    int top=0;
    a[0]=Point(0,a[1].y );
    st[++top]=0;
    st[++top]=1;
    vis[1]=1;
    for(int i=2;i<=n;i++)
    {
       int bestp=-1;double miniAng=inf,minidis=inf;
       for(int j=1;j<=n;j++)  if(!vis[j])
       {
           if(dcmp(Cross( a[st[top]]-a[st[top-1]  ],a[j]-a[st[top]  ]  )   )<0 )  continue;
           double  tAng= Angle(a[st[top]]-a[st[top-1]  ],a[j]-a[st[top]  ] );
           double tdis=dis(a[st[top] ],a[j] );
           if(dcmp(tAng-miniAng)<0 )
           {
               bestp=j;
               miniAng=tAng;
               minidis=tdis;
           }
           else if(dcmp(tAng-miniAng)==0&&dcmp( tdis-minidis  )<0 )
           {
               bestp=j;
               minidis=tdis;
           }
       }
       if(bestp==-1)  break;
       vis[bestp]=1;
       st[++top]=bestp;
    }

    printf("%d",top-1);
    for(int i=2;i<=top;i++)
    {
        printf(" %d",a[st[i]].ind);
    }
    putchar('\n');


}
int main()
{
   std::ios::sync_with_stdio(false);
   int T;cin>>T;
   while(T--)
   {
       cin>>n;
       for1(i,n)
       {
           cin>>a[i].ind>>a[i].x>>a[i].y;
       }
       solve();
   }
   return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值