给定一个 n×mn×m 的二维整数数组,用来表示一个迷宫,数组中只包含 00 或 11,其中 00 表示可以走的路,11 表示不可通过的墙壁。
最初,有一个人位于左上角 (1,1)(1,1) 处,已知该人每次可以向上、下、左、右任意一个方向移动一个位置。
请问,该人从左上角移动至右下角 (n,m)(n,m) 处,至少需要移动多少次。
数据保证 (1,1)(1,1) 处和 (n,m)(n,m) 处的数字为 00,且一定至少存在一条通路。
输入格式
第一行包含两个整数 nn 和 mm。
接下来 nn 行,每行包含 mm 个整数(00 或 11),表示完整的二维数组迷宫。
输出格式
输出一个整数,表示从左上角移动至右下角的最少移动次数。
数据范围
1≤n,m≤1001≤n,m≤100
输入样例:
5 5
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
输出样例:
8
q[N*N]队列的作用是记录宽搜的路线,q[tt]负责记录,q[hh]负责一个个向前遍历。
g[N][N]负责记录题目所给的地图。
d[N][N]负责记录某个位置是否可以走,该位置是走的第几次位置,且记录结果。
由于是宽搜,每一排是一起走的,所以最快到达终点的路线即为最短路,不存在d[N][N]值被替代的情况。
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
const int N = 110;
typedef pair<int, int >PII;
int n, m;
int d[N][N];
int g[N][N];
PII q[N * N];
int bfs()
{
int tt = 0, hh = 0;
memset(d, -1, sizeof d);
d[0][0] = 0;
q[0] = { 0,0 };
int dx[] = { -1,0,1,0 }, dy[] = { 0,-1,0,1 };
while (hh <= tt)
{
auto it = q[hh];
hh++;
for (int i = 0; i < 4; i++)
{
int x = it.first + dx[i], y = it.second + dy[i];
if (x < n && x >= 0 && y < m && y >= 0 && d[x][y] == -1 && g[x][y] == 0)
{
d[x][y] = d[it.first][it.second] + 1;
tt++;
q[tt] = { x,y };
}
}
}
return d[n - 1][m - 1];
}
int main()
{
cin >> n >> m;
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
cin >> g[i][j];
}
}
cout << bfs() << endl;
return 0;
}
若要记录路线:
#include<iostream>
#include<algorithm>
#include<queue>
#include<cstring>
using namespace std;
const int N = 110;
typedef pair<int, int >PII;
int n, m;
int d[N][N];
int g[N][N];
PII q[N * N], fff[N][N];
int bfs()
{
int tt = 0, hh = 0;
memset(d, -1, sizeof d);
d[0][0] = 0;
q[0] = { 0,0 };
int dx[] = { -1,0,1,0 }, dy[] = { 0,-1,0,1 };
while (hh <= tt)
{
auto it = q[hh];
hh++;
for (int i = 0; i < 4; i++)
{
int x = it.first + dx[i], y = it.second + dy[i];
if (x < n && x >= 0 && y < m && y >= 0 && d[x][y] == -1 && g[x][y] == 0)
{
d[x][y] = d[it.first][it.second] + 1;
fff[x][y] = it;
tt++;
q[tt] = { x,y };
}
}
}
int x = n - 1, y = m - 1;
while (x != 0 || y != 0)
{
cout << x << ' ' << y << endl;
auto it = fff[x][y];
x = it.first, y = it.second;
}
return d[n - 1][m - 1];
}
int main()
{
cin >> n >> m;
for (int i = 0; i < n; i++)
{
for (int j = 0; j < m; j++)
{
cin >> g[i][j];
}
}
cout << bfs() << endl;
return 0;
}