River Hopscotch(POJ--3258【二分查找】

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distanceDi from the start (0 < Di < L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks
题意:牛沿着河跳柱子。输入L,n,m分别代表起点与终点的距离,起点与终点之间柱子的数量,要移走的柱子数量(起点与终点也是柱子但是不能移走),接下来n行是每个柱子距起点的距离。求移走m个柱子后,使得牛跳的最少间距最大,求这个最大的最少间距。
思路:用二分不断枚举间距。

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

#include <cstdio>
#include <algorithm>
using namespace std;
int dis[50005],n;
int re(int x)
{
    int cnt=0;
    for(int i=1,j=0; i<=n+1; i++)
    {
        if((dis[i]-dis[j])<=x)     //如果牛能从j跳到i就加加
            cnt++;                      //累加牛能跳到的柱子数    
        else
            j=i;
    }
    return cnt;
}
int main()
{
    //freopen("lalala.text","r",stdin);
    int L,m;
    while(~scanf("%d %d %d",&L,&n,&m))
    {
        dis[0]=0;
        for(int i=1; i<=n; i++)
            scanf("%d",&dis[i]);
        sort(dis+1,dis+n+1);      //将柱子距离按升序排序
        dis[n+1]=L;
        int l=0,r=L*2;              //上限是总长的2倍
        int mid;
        while(l<=r)
        {
            mid=(l+r)/2;
//            printf("l = %d r = %d\nmid = %d\n",l,r,mid);
            int t=re(mid);               //牛能跳到的柱子数
//            printf("t = %d\n",t);
            if(t>m)                          //如果牛能跳到的柱子数比要被撤走的柱子数都多说明此时的距离大了
                r=mid-1;
            else                              //如果牛能跳到的柱子数比要被撤走的柱子数少或相等(如果相等的话说明终点柱子也应该被撤走而终点柱子不能移动,所以也不符合要求)则说明此时的距离小了
                l=mid+1;
        }
        printf("%d\n",l);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值