[PAT-Advanced] A1007 Maximum Subsequence Sum (25)

总题解目录

[PAT- Advanced Level] 甲级题解目录(Advanced Level)

A1007 Maximum Subsequence Sum (25point(s))

Given a sequence of K integers { N​1​​ , N​2​​ , …, N​K​​ }. A continuous subsequence is defined to be { N​i​​ , N​i+1​​ , …, N​j​​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

Analysis

  • 求最长子序列和。如果输入全为负数,则结果要求输出的和为0,并输出整个数组的首尾数据。
  • 使用DP思想。只要所有dp的值都是负数,就可以肯定整个数组中的数据都是负数。
  • 注意读题,最后输出的是对应位置数据的值,而不是位置!

C++ Code

#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include <vector>
#include <string.h>
#define MAX_K 100000

using namespace std;


int main(){
    int k, end_index = 0, max_sum=-1;	// max_sum设置为-1非常关键,若设置为0,过不了测试点5(例:-2 0 0 0 -1)
    int max_subseq_sum[MAX_K];  // 存放到第i个位置为止的最大子序列和
    int start_idx[MAX_K];       // 用于存放到第i个位置为止的最大子序列的起始位置
    int data[MAX_K];            // 存放输入的数据
	memset(max_subseq_sum, 0, sizeof(max_subseq_sum));  // 数组初始置0

    cin >> k;

    for(int i = 0; i < k; i++){
        cin >> data[i];
        if(i == 0){
            max_subseq_sum[i] = data[i];
            start_idx[i] = i;
        }
        else{	// 到第i个位置为止的最大子序列和=max(data[i],max_subseq_sum[i-1]+data[i])
            if(data[i] > max_subseq_sum[i-1] + data[i]){	// data[i]较大时,i作为序列起始位置
                max_subseq_sum[i] = data[i];
                start_idx[i] = i;
            }
            else{	// max_subseq_sum[i-1]+data[i]较大时,起始位置与到i-1为止的最大子序列和的起始位置的相同
                max_subseq_sum[i] = max_subseq_sum[i-1] + data[i];
                start_idx[i] = start_idx[i-1];
            }
        }
        if(max_subseq_sum[i] > max_sum){    	// 找到最大值的结束位置
            max_sum = max_subseq_sum[i];
            end_index = i;
        }
    }

    if(max_subseq_sum[end_index] < 0)
        printf("0 %d %d", data[0], data[k-1]);
    else
        printf("%d %d %d", max_sum, data[start_idx[end_index]], data[end_index]);

	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值