【PAT】A1147 Heaps (30 point(s))


作者: CHEN, Yue
单位: 浙江大学
时间限制: 200 ms
内存限制: 64 MB
代码长度限制: 16 KB

A1147 Heaps (30 point(s)A)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree’s postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

Code

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int m,n;
vector<int> heap;
void postorder(int root){		// 后序遍历,LRN
    if(root >= n+1)   return;
    postorder(root*2);
    postorder(root*2+1);
    printf("%d",heap[root]);
    if(root!=1) printf(" ");
}
int main(){
    scanf("%d %d",&m,&n);
    for(int i=0;i<m;i++){
        heap.resize(n+1);
        for(int j=1;j<=n;j++)   scanf("%d",&heap[j]);
        int fmin=1,fmax=1;
        for(int u=1;u<=n/2;u++){
            int v=2*u;
            if(v+1<=n){
                if(!(heap[u]<heap[v]&&heap[u]<heap[v+1])) fmin=-1;
                if(!(heap[u]>heap[v]&&heap[u]>heap[v+1])) fmax=-1;
            }
            else{
                if(heap[u]>heap[v]) fmin=-1;
                if(heap[u]<heap[v]) fmax=-1;
            }
        }
        if(fmin==1) printf("Min Heap\n");
        else if(fmax==1)    printf("Max Heap\n");
        else    printf("Not Heap\n");
        postorder(1);
        printf("\n");
    }
    return 0;
}

Analysis

-已知有m棵树,并且给出每棵树的层序遍历。

-判断这棵树是大顶堆还是小顶堆或者根本不是堆,并且输出这棵树的后序遍历。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值