ZOJ 3609 Modular Inverse 扩展欧几里得

Modular Inverse

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The modular modular multiplicative inverse of an integer a modulo m is an integer x such that a-1x (mod m). This is equivalent to ax≡1 (mod m).

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.

Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input
3
3 11
4 12
5 13
Sample Output
4
Not Exist

8

假设以a距离走x步,b距离走y步,则相当于求 a*x+b*y=c,如果len%c=0则有解。

则通解为x=x0+b/c*t,y=y0-a/c*t。当x=y是步数为最小。

这是另t=(y-x)/(a+b),如果t为小数,则答案一定在[t-1,t+1]范围之内,因此直接在范围内找最小值。

当x,y同号时,因为可以走(a+b)的距离,最小步数一定为max(x,y)。

当x,y异号时,最小步数为abs(x)+abs(y)。

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
#define ll long long
ll e_gcd(ll a, ll b, ll &x, ll &y)
{
	if (b == 0)
	{
		x = 1;
		y = 0;
		return a;
	}
	ll ans = e_gcd(b, a%b, x, y);
	ll temp = x;
	x = y;
	y = temp - (a / b)*y;
	return ans;
}
ll work(ll a, ll b, ll c)
{
	ll x, y, gcd, ans, t, step;
	gcd = e_gcd(a, b, x, y);
	if (c%gcd != 0) return -1;
	a /= gcd, b /= gcd;
	x = c / gcd*x;
	y = c / gcd*y;
	ans = 1e18;
	t = (y - x) / (a + b);
	for (ll i = t - 1;i <= t + 1;i++)
	{
		if (abs(x + b*i) + abs(y - a*i) == abs(x + b*i + y - a*i))
			step = max(abs(x + b*i), abs(y - a*i));
		else
			step = abs(x + b*i) + abs(y - a*i);
		ans = min(ans, step);
	}
	return ans;
}
int main()
{
	ll a, b, c, t, s, e, x, y;
	scanf("%lld", &t);
	while (t--)
	{
		scanf("%lld%lld%lld%lld", &s, &e, &a, &b);
		printf("%lld\n", work(a, b, e - s));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值