5103: Electric Fence

文章讨论了如何使用皮克定理计算由整数坐标点构成的三角形电围栏内可以容纳的奶牛数量,给定三个边界点的坐标。关键步骤包括应用公式:内点数+边界点数÷2-1。
摘要由CSDN通过智能技术生成

描述

In this problem, "lattice points" in the plane are points with integer coordinates.

In order to contain his cows, Farmer John constructs a triangular electric fence by stringing a "hot" wire from the origin (0,0) to a lattice point [n,m] (0<=n<32,000, 0<m<32,000), then to a lattice point on the positive x axis [p,0] (0<p<32,000), and then back to the origin (0,0).

A cow can be placed at each lattice point within the fence without touching the fence (very thin cows). Cows can not be placed on lattice points that the fence touches. How many cows can a given fence hold?

输入

The single input line contains three space-separated integers that denote n, m, and p.

输出

A single line with a single integer that represents the number of cows the specified fence can hold.

样例输入

7 5 10

样例输出

20

此题用到皮克定理

格点多边形面积=内点数+边界点数÷2-1

代码

 #include<bits/stdc++.h>
using namespace std;
int gcd(int x,int y)
{
    if(y==0)
        return x;
    return gcd(y,x%y);
}
int main()
{
    int n,m,p;
    cin>>n>>m>>p;
    double s=p*m/2.0,s1=p;
    s1+=gcd(n,m);
    s1+=gcd(abs(p-n),m);
    cout<<(int)(s-s1/2+1);
 } 

评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值