PAT-A1070/B1020 Mooncake/月饼 题目内容及题解

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

月饼是中国人在中秋佳节时吃的一种传统食品,不同地区有许多不同风味的月饼。现给定所有种类月饼的库存量、总售价、以及市场的最大需求量,请你计算可以获得的最大收益是多少。

注意:销售时允许取出一部分库存。样例给出的情形是这样的:假如我们有 3 种月饼,其库存量分别为 18、15、10 万吨,总售价分别为 75、72、45 亿元。如果市场的最大需求量只有 20 万吨,那么我们最大收益策略应该是卖出全部 15 万吨第 2 种月饼、以及 5 万吨第 3 种月饼,获得 72 + 45/2 = 94.5(亿元)。

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (≤1000), the number of different kinds of mooncakes, and D (≤500 thousand tons), the maximum total demand of the market. Then the second line gives the positive inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

每个输入包含一个测试用例。每个测试用例先给出一个不超过 1000 的正整数 N 表示月饼的种类数、以及不超过 500(以万吨为单位)的正整数 D 表示市场最大需求量。随后一行给出 N 个正数表示每种月饼的库存量(以万吨为单位);最后一行给出 N 个正数表示每种月饼的总售价(以亿元为单位)。数字间以空格分隔。

(量纲不同,但是数值相同)

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.

对每组测试用例,在一行中输出最大收益,以亿元为单位并精确到小数点后 2 位。

Sample Input:

3 200
180 150 100
7.5 7.2 4.5

Sample Output:

9.45

解题思路

  1. 读入数据,并计算单价;
  2. 按单价从大到小排序;
  3. 用贪心算法尽可能多选单价最高的商品以获得最高收益;
  4. 输出结果并返回零值。

代码

#include<cstdio>
#include<algorithm>
#define maxn 1010
using namespace std;

struct Cake{
    double price,amounts,ave;
}c[maxn];

bool cmp(Cake a,Cake b){
    return a.ave>b.ave;
}

int main(){
    int N,i;
    double D,sum=0.0;
    scanf("%d%lf",&N,&D);
    for(i=0;i<N;i++){
        scanf("%lf",&c[i].amounts);
    }
    for(i=0;i<N;i++){
        scanf("%lf",&c[i].price);
        c[i].ave=c[i].price/c[i].amounts;
    }
    sort(c,c+N,cmp);
    for(i=0;i<N;i++){
        if(D>=c[i].amounts){
            sum+=c[i].price;
            D-=c[i].amounts;
        }else{
            sum+=D*c[i].ave;
            break;
        }
    }
    printf("%.2f\n",sum);
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值