HDU 1325 Is It A Tree? 并查集

HDU 1325 Is It A Tree?
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.
There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

在这里插入图片描述在这里插入图片描述在这里插入图片描述

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.
Output
For each test case display the line Case k is a tree." or the lineCase k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).
Sample Input
6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1
Sample Output
Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.

这个题就是用并查集判断是否为树,但是注意这个是个有向树。。有点思维定式了,一直以为是无向的。
有以下几个坑的地方:
(1) 以小于 0 的数结束
(2) 空树也是符合要求的,也就是一开始就输入0 0
(3) 还要判断是否为森林
(4) 因为是有向图树,那么在合并前,需要判断一下 y 的入度是否为0,不为0的话肯定不符合树的要求
(5) 重边也是不行的,但是用并查集的话这个很好判断
(6) n好像还没有范围,我开了1e5就过了
其他的地方跟无向图一样处理,当要合并的两个点在一个集合中不符合要求。


#include<cstdio>
#include<iostream>
#include<string>
#include<cstring>
#include<map>
#include<cmath>
#include<cctype>
#include<vector>
#include<set>
#include<queue>
#include<algorithm>
#include<sstream>
#define X first
#define Y second
#define L (u<<1)
#define R (u<<1|1)
#define Mid (tr[u].l+tr[u].r>>1)
#define Len(u) (tr[u].r-tr[u].l+1)
using namespace std;

typedef long long LL;
typedef pair<int,int> PII;

const int N=100010,mod=1e9+7,INF=0x3f3f3f3f;
const double eps=1e-6;

int x,y;
int p[N],r[N];//r是入度,p是并查集的集合

void init()
{
    for(int i=0;i<N;i++)
        p[i]=i,r[i]=0;
}

int find(int x)
{
    if(x!=p[x]) p[x]=find(p[x]);
    return p[x];
}

int main()
{
//	ios::sync_with_stdio(false);
//	cin.tie(0);

    int T=0;
    while(scanf("%d%d",&x,&y)!=EOF&&(x>=0&&y>=0))
    {
        if(x==0&&y==0)
        {
            printf("Case %d is a tree.\n",++T);
            continue;
        }
        init();

        int root=x;//记一下 root
        bool f=true;
        int px=find(x),py=find(y);
        if(px==py) f=false;
        else p[py]=px,r[y]++;

        while(scanf("%d%d",&x,&y)&&(x!=0||y!=0))
        {
            if(r[y]>0)
            {
                f=false;
                continue;
            }
            r[y]++;
            int px=find(x),py=find(y);
            if(px==py) f=false;
            else p[py]=px;
        }

        root=find(root);
        for(int i=1;i<=1e5;i++)//判断森林
            if(i!=find(i)&&find(i)!=root)
            {
                f=false;
                break;
            }

        if(f) printf("Case %d is a tree.\n",++T);
        else printf("Case %d is not a tree.\n",++T);
    }




	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值