【PAT】1002. A+B for Polynomials(25)

1002. A+B for Polynomials(25)

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2

分析:读题,看到要按序输出,考虑定义结构+优先队列;小数点保留1一位。
细节:系数为0时要去掉。

#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <vector>
using namespace std;

typedef struct _node
{
	int n;
	double a;
}node;

struct cmp{
	bool operator()(const struct _node &x, const struct _node &y){
		return x.n < y.n;
	}
};

priority_queue<node,vector<node>, cmp> q1,q2,q;


int main()
{
//	freopen("test.txt","r",stdin);
	int k;
	cin>>k;
	while(k--){
		int n;
		double a;
		cin>>n>>a;
		node x;
		x.n=n;
		x.a=a;
		q1.push(x);
	} 
	cin>>k;
	while (k--){
		int n;
		double a;
		cin>>n>>a;
		node x;
		x.n=n;
		x.a=a;
		q2.push(x);
	}
	while (!q1.empty() && !q2.empty()){
		node x1=q1.top(),x2=q2.top();
		node y;
		if (x1.n==x2.n) {
			y.a=x1.a+x2.a;
			if (y.a!=0){ //
				y.n=x1.n;		
				q.push(y);
			}
			q1.pop();
			q2.pop();	
		}
		else if (x1.n>x2.n){
			q.push(x1);
			q1.pop();
		}
		else if (x1.n<x2.n){
			q.push(x2);
			q2.pop();
		}
	}
	while (!q1.empty()){
		node x1=q1.top();
		q.push(x1);
		q1.pop();
	}
	while (!q2.empty()){
		node x2=q2.top();
		q.push(x2);
		q2.pop();
	}
	cout<<q.size();
	while (!q.empty()){
		node x=q.top();
		printf(" %d %.1f",x.n,x.a);//
		q.pop();
	}
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值