算法笔记练习 3.3 图形输出 问题 B: Hello World for U

算法笔记练习 题解合集

本题链接

题目

题目描述
Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:

h d

e l

l r

lowo

That is, the characters must be printed in the original order, starting top-down from the left vertical line with n1 characters, then left to right along the bottom line with n2 characters, and finally bottom-up along the vertical line with n3 characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n1 = n3 = max { k| k <= n2 for all 3 <= n2 <= N } with n1 + n2 + n3 - 2 = N.

输入
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

输出
For each test case, print the input string in the shape of U as specified in the description.

样例输入

helloworld!

样例输出

h   !
e   d
l   l
lowor

思路

headtail两个指针分别从字符串的两边向中间遍历,于是除了最后一行之外,每一行都由两个指针指向的字符以及中间的空格构成。

代码中两层for循环的循环次数分别是出最后一行外的行数以及中间的空格数,具体次数是找规律得出的,详见下方代码。

代码

#include <cstdio>
#include <cstring>
#define MAX 501
int main() {
	char str[MAX];
	scanf("%s", &str); 
	int n = strlen(str);
	char *head = str;
	char *tail = str + n - 1;
	int i, j;
	for (i = 0; i < (n + 2) / 3 - 1; ++i) {
		putchar(*head++);
		for(j = 0; j < (n + 2) / 3 + (n + 2) % 3 - 2; ++j)
			putchar(' ');
		putchar(*tail--);
		putchar('\n'); 
	}
	while (head <= tail)
		putchar(*head++);
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值