Find a way (双重BFS)

Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
Sample Input
4 4
Y.#@
....
.#..
@..M
4 4
Y.#@
....
.#..
@#.M
5 5
Y..@.
.#...
.#...
@..M.
#...#
Sample Output
66
88

66

问题简述:双重bfs,即对两个点各用了一次广搜,题意很简单,有些细节。

在两个细节上卡壳了:1.bfs里一开始在判断到达kfs(即@)后就continue;想的到达kfs就不能再走了,这里应该是可以经过kfs..串门..

2.每次test时dis数组没有memset....

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
using namespace std;

int way[4][2] = {{1,0},{-1,0},{0,1},{0,-1}};
int vis[210][210];
char maze[210][210];
int dis[2][210][210];
int x[2],y[2];
int n,m;

struct node
{
	int x,y,step;
};

void bfs(int i,int x,int y)
{
	queue<node>q;
	node cur,tmp;
	int t=0;
	
	cur.x = x;
	cur.y = y;
	cur.step = 0;
	vis[cur.x][cur.y] = 1;
	q.push(cur);
	
	while(!q.empty())
	{
		cur = q.front();
		q.pop();
		if (maze[cur.x][cur.y] == '@')
		{	
			dis[i][cur.x][cur.y] = cur.step;
			//continue;
		}
		
		for(int j=0; j<4; j++)
		{
			tmp.x = cur.x + way[j][0];
			tmp.y = cur.y + way[j][1];
			if (tmp.x>=0 && tmp.y>=0 && tmp.x<n && tmp.y<m)
			{
				if (maze[tmp.x][tmp.y] != '#' && vis[tmp.x][tmp.y]==0)
				{
					tmp.step = cur.step + 1;
					vis[tmp.x][tmp.y] = 1;
					q.push(tmp);
				} 
			}
		}
	}
}


int main()
{	
	while(~scanf("%d%d",&n,&m))
	{
		getchar();
		for(int i=0; i<n; i++)
		{
			scanf("%s",maze[i]);
			for(int j=0;j<m; j++)
			{
				if (maze[i][j] == 'Y')
				{
					x[0] = i;
					y[0] = j;
				}
				if (maze[i][j] == 'M')
				{
					x[1] = i;
					y[1] = j;
				}
			} 
		}	
		memset(dis,0,sizeof(dis));
		for(int i=0; i<2; i++)
		{
			memset(vis,0,sizeof(vis));
			bfs(i,x[i],y[i]);	
		}

		int minx=9999999;
		for(int j=0; j<n; j++)
		{
			for(int k=0; k<m; k++)
			{
				if (dis[0][j][k])
				{
					int step1,step2;
					step1 = dis[0][j][k];
					step2 = dis[1][j][k];
					if (step1+step2 < minx)
						minx = step1+step2;
				}
			}
		}
		printf("%d\n",minx*11);
	}
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值