Largest Rectangle in a Histogram

A histogram is a polygon composed of a sequence of rectangles aligned at a common base line. The rectangles have equal widths but may have different heights. For example, the figure on the left shows the histogram that consists of rectangles with the heights 2, 1, 4, 5, 1, 3, 3, measured in units where 1 is the width of the rectangles: 

Usually, histograms are used to represent discrete distributions, e.g., the frequencies of characters in texts. Note that the order of the rectangles, i.e., their heights, is important. Calculate the area of the largest rectangle in a histogram that is aligned at the common base line, too. The figure on the right shows the largest aligned rectangle for the depicted histogram.
Input
The input contains several test cases. Each test case describes a histogram and starts with an integer  n, denoting the number of rectangles it is composed of. You may assume that  1<=n<=100000. Then follow  n integers  h1,...,hn, where 0<=hi<=1000000000. These numbers denote the heights of the rectangles of the histogram in left-to-right order. The width of each rectangle is  1. A zero follows the input for the last test case.
Output
For each test case output on a single line the area of the largest rectangle in the specified histogram. Remember that this rectangle must be aligned at the common base line.
Sample Input
7 2 1 4 5 1 3 3
4 1000 1000 1000 1000
0
Sample Output
8
4000
Hint
Huge input, scanf is recommended.


问题分析:直接枚举每个高度的左右边界的话肯定是会超时的,所以这里要用dp,想法是当第i-1个比第i个高的时候,那么第i-1个左边界一定是第i个的左边界,比如这个边界是n,如果第n个比第i个仍然高的话,那么进行同样的操作,同理,右边当第i+1个比第i个高的时候,那么第i+1的右边界一定是第i个的右边界,一次类推,最后计算,

但是这里有个坑:h[0]和h[n+1]必须设置为负数,不能为0,要不然会出问题,似乎高度可以使0

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
using namespace std;

int l[100010],r[100010];
long long int data[100010];
int n;

int main()
{
	while(~scanf("%d",&n))
	{
		if (n == 0)
			break;

		for(int i=1; i<=n; i++)
		{
			scanf("%lld",&data[i]);
			l[i] = r[i] = i;
		}
		data[0] = data[n+1] = -1;
		
		for(int i=1; i<=n; i++)
		{
			//计算每条左边比他高的数量 
			while(data[l[i] - 1] >= data[i])
				l[i] = l[l[i] - 1];
		}
		for(int i=n; i>=1; i--)
		{
			//计算每条右边比他高的数量
			while(data[r[i] + 1] >= data[i])
				r[i] = r[r[i] + 1]; 
		}
		 		
		long long int maxn = 0;
		for(int i=1; i<=n; i++)
		{
		//	printf("__ _%d  %d __%d\n",data[i],l[i],r[i]);
			if (maxn < data[i] * (r[i] - l[i] + 1))
				maxn = data[i] * (r[i] - l[i] + 1);
	
		} 
		
		printf("%lld\n",maxn);
	}
	
	return 0;
	
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值