How to Type

Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
Sample Input
3
Pirates
HDUacm
HDUACM
Sample Output
8
8
8


        
  
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

        
 


问题分析:网上很多用的dp,我不是很懂,没用,想法是如果有连续的大写且cap关闭时就要开cap,否则用shift,或者有连续的小写且cap开启时就要关cap,否则用shift(因为有两个或两个以上的字符为大写与小写需要转化时,2个是临界点,此时无论用shift还是cap都是一样的次数,但是当数量增多时那么cap次数就会更少)

具体见代码


#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

const int N = 110;
char s[N];

int main()
{
	int t ;
	
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",s);
		int len = strlen(s);
		int flag = 0;	//表示caplock是否开启
		int cnt = 0;
		
		for(int i=0; i<len; i++)
		{
			if (s[i] >= 'A' && s[i] <= 'Z')
			{
				if (flag == 0)	//如果是大写字母,并且cap没开,假设用shift,cnt++ 
					cnt++;			
				if (s[i+1] >= 'A' && s[i+1] <= 'Z')	//如果下一个也是大写字母,打开cap,相当于这个字符用cap输入 
					flag = 1;		//如果之前flag==0,且下一个也为大写,那么之前的cnt++相当于打开cap,如果flag==1,那么只需增加按键次数 
				cnt++;		//增加按键次数 
			 	//如果在这之前flag已经为1,那么cnt只增加一次按键的次数,没错,否则就要增加两次,一次开caplock,一次按键,下面同理(变为关闭cap) 
			}	
			else	//小写字符 
			{
				if (flag == 1)	//cap打开的,假设用的shift 
					cnt++; 
				if ((s[i+1] >= 'a' && s[i+1] <= 'z') || s[i+1] == 0)	//如果下一个字符仍是小写,后者已是最后一个字符,那么关闭
					flag = 0;
				cnt++;	
				
			}
		}
		if (flag) 	//如果最后几个是连续的大写字母,那么完时caplock是开着的,此时要关闭 
			cnt++;	
		printf("%d\n",cnt);
	}	
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值