Integer Factorization (30)

The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.

Input Specification:

Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.

Output Specification:

For each case, if the solution exists, output in the format:

N = n1^P + ... nK^P

where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL

If there is no solution, simple output "Impossible".

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible



问题分析:深搜咯,不过有几个要注意的地方

                1.一定是sum >=maxn,而不仅仅是大于,因为说了“If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL”,就是当和相同时,取数较大的一个序列,即(6,6,4,4,1)比(6,6,5,3,1)大,那么就肯定是最后一个最佳值

                2.这里用pow的话算出来有问题

                3.输出格式要注意,很容易出错

                4.我本来是在dfs里判断的时候是用的 i<=sqrt(n)+1,结果段错误,还不明白是什么原因....



#include<bits/stdc++.h>
#include<vector>
using namespace std;

int maxn = 0;
int flag;
int num[25];
vector<int>ans,v;

void dfs(int start,int sum,int n,int k)
{
	if (k == 0 && n == 0){
		if (sum >= maxn){
			maxn = sum;
			ans = v;
			return ;
		}
	}

	for(int i = start; i <= 20; i++){
		if (n - num[i] < 0)
			break;
		v.push_back(i);
		dfs(i,sum+i,n-num[i],k-1);
		v.pop_back();
	} 
}

int main()
{
	int n,k,p;
	cin >> n >> k >> p;
	
	for(int i = 1; i <= 20; i++){
		num[i] = 1;
		for(int j = 0; j < p; j++)
			num[i] *= i;
	}

	dfs(1,0,n,k);
	
	if (ans.size() == 0)
		cout << "Impossible" << endl;
	else{
		cout << n << " = ";
                for(int i = ans.size()-1; i >= 0; i--){
                printf("%d^%d",ans[i],p);
                if (i != 0)
                    printf(" + ");
                } 
		cout << endl;
	} 
	return 0;		
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值