Subsequence

 

A sequence of N positive integers (10 < N < 100000), each of them less than or equal 10000, and a positive integer S (S <100 000 000) are given. Write a program to find the minimal length of thesubsequence of consecutive elements of the sequence, the sum of which isgreater than or equal to S.

Input

The first line is the number of test cases. For each testcase the program has to read the numbers N and S, separated by an interval,from the first line. The numbers of the sequence are given in the second lineof the test case, separated by intervals. The input will finish with the end offile.

Output

For each the case the program has to print the result onseparate line of the output file.if no answer, print 0.

Sample Input

2

10 15

5 1 3 5 10 7 4 9 2 8

5 11

1 2 3 4 5

Sample Output

2

3


问题分析:用arr[i]表示前i个数字的和,在都是正数的情况下肯定是越来越大的,那么可以证明在终点一定时,一步步增大起点缩小区间,然后缩小到和小于S后,增大终点,再继续讨论,不断比较得到最小区间。

(如果终点增大起点减小,那么之间的和一定增大,所以只要单向移动即可)


#include<bits/stdc++.h>
using namespace std;


int main()
{
	int T;
	int N,S;
	int arr[100010] = {0};
	
	cin >> T;
	while(T--){
		cin >> N >> S;
		int t;
		
		memset(arr,0,sizeof(arr));
		for(int i = 1; i <= N; i++){
			cin >> t;
			arr[i] = arr[i-1]+t;
		}
		
		
		int s = 1;
		int ans = N+1;
		
		for(int e = 1; e <= N; e++){
			if (arr[e] - arr[s-1] < S)
				continue;
			
			while(arr[e] - arr[s-1] >= S)		//这里循环结束时s多移了一位,e-s+1为当前的长度,最后结果加1为满足条件时的长度 
				s++;
			
	
			ans = min(ans,e-s+1);	
				
		}
		
		if (ans == N+1)
			printf("0\n");
		else	
			printf("%d\n",ans+1);	
		
	}

	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值