bzoj 1655: [Usaco2006 Jan] Dollar Dayz 奶牛商店(高精度完全背包)

1655: [Usaco2006 Jan] Dollar Dayz 奶牛商店

Time Limit: 5 Sec   Memory Limit: 64 MB
Submit: 599   Solved: 306
[ Submit][ Status][ Discuss]

Description

Farmer John goes to Dollar Days at The Cow Store and discovers an unlimited number of tools on sale. During his first visit, the tools are selling variously for $1, $2, and $3. Farmer John has exactly $5 to spend. He can buy 5 tools at $1 each or 1 tool at $3 and an additional 1 tool at $2. Of course, there are other combinations for a total of 5 different ways FJ can spend all his money on tools. Here they are: 1 @ US$3 + 1 @ US$2 1 @ US$3 + 2 @ US$1 1 @ US$2 + 3 @ US$1 2 @ US$2 + 1 @ US$1 5 @ US$1 Write a program than will compute the number of ways FJ can spend N dollars (1 <= N <= 1000) at The Cow Store for tools on sale with a cost of $1..$K (1 <= K <= 100).

    约翰到奶牛商场里买工具.商场里有K(1≤K≤100).种工具,价格分别为1,2,…,K美元.约翰手里有N(1≤N≤1000)美元,必须花完.那他有多少种购买的组合呢?

Input

A single line with two space-separated integers: N and K.

    仅一行,输入N,K.

Output

A single line with a single integer that is the number of unique ways FJ can spend his money.

    不同的购买组合数.

Sample Input

5 3

Sample Output

5


很简单的完全背包

但答案可能非常大,N=1000;K=100的时候大概有20多位,所以要用高精度

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
typedef struct Bnum
{
	int l;
	int s[35];
	Bnum()
    {
        l = 0;
        memset(s, 0, sizeof(s));
    }
}Bnum;
Bnum operator + (Bnum x, Bnum y)
{
	int i;
	Bnum z;
	z.l = max(x.l, y.l);
	for(i=1;i<=z.l;i++)
	{
		z.s[i] += x.s[i]+y.s[i];
		if(z.s[i]>999999999)
		{
			z.s[i+1] += 1;
			z.s[i] -= 1000000000;
		}
	}
	while(z.s[z.l+1])
		z.l++;
	return z;
}
void Print(Bnum x)
{
	int i;
	for(i=x.l;i>=1;i--)
		printf("%d", x.s[i]);
	printf("\n");
}
Bnum dp[1005];
int main(void)
{
	int i, n, j, k;
	scanf("%d%d", &k, &n);
	for(i=1;i<=k;i++)
		dp[i].l = dp[i].s[1] = 0;
	dp[0].l = dp[0].s[1] = 1;
	for(i=1;i<=n;i++)
	{
		for(j=i;j<=k;j++)
			dp[j] = dp[j]+dp[j-i];
	}
	Print(dp[k]);
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值