B - Dungeon Master // bfs 广度优先搜索 三维数组

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?
Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!


这个网址有BFS例子具体的实现过程:

走迷宫具体的实现过程 很详细

https://wenku.baidu.com/view/97c9220452ea551810a687e4.html

 //走迷宫问题用bfs来做,会判断这一个点是否可走,找到最优路径 
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<iostream>
#include<algorithm>
using namespace std;
struct node
{
	int L,R,C;
	int step;
}t[1000001];
struct node p,q,w,l;
char mp3[31][31][31]; 
int dir3[][3]={0,0,1,0,0,-1,0,-1,0,0,1,0,-1,0,0,1,0,0};
int vis[31][31][31];
int L,R,C;
void bfs() // 用队列来实现  
{
	vis[p.L][p.R][p.C]=1;
	int front=0;
	int rear=0;
	t[rear++]=p;
	while(front!=rear)
	{
	    w=t[front++];
		if(w.L==q.L && w.R==q.R && w.C==q.C)//判断是否到达终点  
		{
		   printf("Escaped in %d minute(s).\n",w.step);
		    return ;
		} 	
		for(int i=0;i<6;i++)
		{
			l=w;
			l.L=l.L+dir3[i][0];
			l.R=l.R+dir3[i][1];
			l.C=l.C+dir3[i][2];
			if(l.L>=0&&l.L<L&&l.R>=0&&l.R<R&&l.C>=0&&l.C<C&&mp3[l.L][l.R][l.C]!='#'&&vis[l.L][l.R][l.C]==0)
			{
				l.step++;
				vis[l.L][l.R][l.C]=1;
				t[rear++]=l;
			}
		}
	}
	printf("Trapped!\n");
}
int main()
{
  while(scanf("%d%d%d",&L,&R,&C)!=EOF)
  {
  	   getchar();
  	  memset(mp3,0,sizeof(mp3));
  	  memset(vis,0,sizeof(vis)); 
  	  memset(t,0,sizeof(t)) ;
     if(L==0 || R==0 || C==0)
	 { 
	   break;
	 }	
	 for(int i=0;i<L;i++) //三维字符串的输入方式
	 {
	 	for(int j=0;j<R;j++)
	 	{
	 		scanf("%s",mp3[i][j]);
	 		for(int k=0;k<C;k++)
	 		{
   	     	      if(mp3[i][j][k]=='S') //起点
	 		  {
	 		  	p.L=i;
	 		  	p.R=j;
	 		  	p.C=k;
	 		  	p.step=0;
			  }	
			else if(mp3[i][j][k]=='E') //终点 
		      {
		      	q.L=i;
		      	q.R=j;
		      	q.C=k;
			  }
			}
	     }
	 }
    bfs();
  }
  return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值