ACM: 贪心法 poj 1700

                                                                              Crossing River

 

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

 

题意: 要全部人过河, 每次穿只可以载两个人, 过河的时间是按照时间长的人计算(两人过河的情况).

 

解题思路:

          1. 贪心法: 剩下3个人一下可以直接计算. 下面是人数>=4的情况.

               决策1: 先最快的和次快的过河, 最快的将船划回来, 再当前最慢和次慢的一起过河,

                      次快的将船划回来.(完成了将当前最慢和次慢送过河)

                      int t1 = a[1] + a[0] + a[n] + a[1];

               决策2: 每次都是最快和当前最慢的一起过河,最快的将串划回来.

                      int t2 = 2*a[0] + a[n] + a[n-1];

               每次都选出这次决策的最优解. sum += min(t1,t2);

          2. 剩下3人的情况: sum += a[2] + a[0] + a[1];

             剩下2人的情况: sum += a[1];

             剩下1人的情况: sum += a[0]; (只有一个人的情况)

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <cstdlib>
using namespace std;
#define MAX 1005

int n;
int a[MAX];

int cmp(const void *a,const void *b)
{
 return *(int*)a - *(int*)b;
}

inline int min(int a,int b)
{
 return a < b ? a : b;
}

int main()
{
// freopen("input.txt","r",stdin);
 int caseNum;
 int i;
 scanf("%d",&caseNum);
 while(caseNum--)
 {
  scanf("%d",&n);
  for(i = 0; i < n; ++i)
   scanf("%d",&a[i]);
  qsort(a,n,sizeof(a[0]),cmp);

  int sum = 0;
  for(i = n-1; i > 2; i -= 2)
  {
   int t1 = 2*a[1] + a[0] + a[i];
   int t2 = 2*a[0] + a[i] + a[i-1];
   sum += min(t1,t2);
  }

  if(i == 2) sum += a[2] + a[0] + a[1];
  else if(i == 1) sum += a[1];
  else sum += a[0];
  printf("%d\n",sum);
 }

 return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值