2015 南阳理工CCPC Ancient Go

Ancient Go
Time Limit:1000MS     Memory Limit:65535KB     64bit IO Format:%lld & %llu

Description

Yu Zhou likes to play Go with Su Lu. From the historical research, we found that there are much difference on the rules between ancient go and modern go.

Here is the rules for ancient go they were playing:

  • The game is played on a 8*8cell board, the chess can be put on the intersection of the board lines, so there are 9*9different positions to put the chess.
  • Yu Zhou always takes the black and Su Lu the white. They put the chess onto the game board alternately.
  • The chess of the same color makes connected components(connected by the board lines), for each of the components, if it's not connected with any of the empty cells, 
    this component dies and will be removed from the game board.
  • When one of the player makes his move, check the opponent's components first. After removing the dead opponent's components, check with the player's components and remove 
    the dead components.

One day, Yu Zhou was playing ancient go with Su Lu at home. It's Yu Zhou's move now. But they had to go for an emergency military action. Little Qiao looked at the game board and 
would like to know whether Yu Zhou has a move to kill at least one of Su Lu's chess.

Input

The first line of the input gives the number of test cases, T(1<=T<=100). T test cases follow. Test cases are separated by an empty line. Each test case consist of 9 lines represent the game board. Each line consists of 9 characters. Each character represents a cell on the game board. . represents an empty cell. x represents a 
cell with black chess which owned by Yu Zhou. o represents a cell with white chess which owned by Su Lu.

Output

For each test case, output one line containing Case #x: y, where x is the test case number (starting from 1) and y is Can kill in one move!!! if Yu Zhou 
has a move to kill at least one of Su Lu's components. Can not kill in one move!!! otherwise.

Sample Input

2

…….xo 
……… 
……… 
..x…… 
.xox….x 
.o.o…xo 
..o…… 
…..xxxo 
….xooo.

……ox. 
…….o. 
…o….. 
..o.o…. 
…o….. 
……… 
…….o. 
…x….. 
……..o

Sample Output

Case #1: Can kill in one move!!! 
Case #2: Can not kill in one move!!!

Hint

In the first test case, Yu Zhou has 4 different ways to kill Su Lu's component.

In the second test case, there is no way to kill Su Lu's component.

题解: 首先, 把棋盘上该拿走的黑棋拿走, 然后枚举每一个可以放子的点, 暴力dfs即可.



#include <cstdio>
#include <cstring>

const int N = 13;

char mp[N][N];
int dx[] = {1, -1, 0, 0};
int dy[] = {0, 0, 1, -1};
bool vis[N][N];

bool is_point(int x, int y) {
	return x >= 0 && x < 9 && y >= 0 && y < 9;
}

bool check(int x, int y, char ch) {
	vis[x][y] = true;
	if (mp[x][y] != ch) {
		if (mp[x][y] == '.') return false;
		else return true;
	}

	bool flag = true;
	for (int i = 0; i < 4; ++i) {
		int tx = x + dx[i];
		int ty = y + dy[i];
		if (is_point(tx, ty) && !vis[tx][ty]) {
			flag = flag && check(tx, ty, ch);
		}
	}
	return flag;
}

void clear(int x, int y, char ch) {
	mp[x][y] = '.';
	for (int i = 0; i < 4; ++i) {
		int tx = x + dx[i];
		int ty = y + dy[i];
		if (is_point(tx, ty) && mp[tx][ty] == ch)
			clear(tx, ty, ch);
	}
}

int main() {
	int T;
	scanf("%d", &T);

	while (T--) {
		for (int i = 0; i < 9; ++i)
			scanf("%s", mp[i]);

		for (int i = 0; i < 9; ++i) {
			for (int j = 0; j < 9; ++j) {
				if (mp[i][j] == 'x') {
					memset(vis, false, sizeof(vis));
					if (check(i, j, 'x') == true)
						clear(i, j, 'x');
				}
			}
		}

		bool flag = false;

		for (int i = 0; i < 9; ++i) {
			for (int j = 0; j < 9; ++j) {

				if (mp[i][j] == '.') {
					mp[i][j] = 'x';

					for (int k = 0; k < 4; ++k) {
						int tx = i + dx[k];
						int ty = j + dy[k];
						memset(vis, false, sizeof(vis));
						if (is_point(tx, ty) && mp[tx][ty] == 'o' && check(tx, ty, 'o')) {
							flag = true;
							break;
						}
					}
					mp[i][j] = '.';
				}
			}
		}

		static int cnt = 0;
		printf("Case #%d: ", ++cnt);
		if (flag) puts("Can kill in one move!!!");
		else puts("Can not kill in one move!!!");
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值