2015南阳理工CCPC Sudoku

Sudoku

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)
 

Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.

Actually, Yi Sima was playing it different. First of all, he tried to generate a  4×4  board with every row contains  1  to  4 , every column contains  1  to  4 . Also he made sure that if we cut the board into four  2×2  pieces, every piece contains  1  to  4 .

Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.

Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!

Input

The first line of the input gives the number of test cases,  T ( 1T100 ).  T  test cases follow. Each test case starts with an empty line followed by  4  lines. Each line consist of  4 characters. Each character represents the number in the corresponding cell (one of 1234). * represents that number was removed by Yi Sima.

It's guaranteed that there will be exactly one way to recover the board.

Output

For each test case, output one line containing Case #x:, where  x  is the test case number (starting from  1 ). Then output  4  lines with  4  characters each. indicate the recovered board.

Sample input and output

Sample Input Sample Output
3

****
2341
4123
3214

*243
*312
*421
*134

*41*
**3*
2*41
4*2*
Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123

Source

The 2015 China Collegiate Programming Contest
题解: 这题爆搜即可过, 我们可以设三个标记数组, vis1[i][j] 表示第i行是否出现过j, vis2[i][j]表示第i列是否出现过j, vis3[i][j] 表示四个小区域中是否出现过j
然后用dfs搜索即可.


#include <cstdio>
#include <cstring>

const int N = 6;
char mp[N][N];
bool vis1[N][N], vis2[N][N], vis3[N][N];
bool found;

void search(int cur) {
	if (cur == 16) {
		found = true;
		return ;
	}
	int r = cur / 4, c = cur % 4;
	int idx = mp[r][c] - '0';

	if (mp[r][c] == '*') {
		for (int i = 1; i <= 4; ++i) {
			if (!vis1[r][i] && !vis2[c][i] && !vis3[r / 2 * 2 + c / 2][i]) {
				vis1[r][i] = vis2[c][i] = vis3[r / 2 * 2 + c / 2][i] = true;
				mp[r][c] = '0' + i;
				search(cur + 1);
				if (found) break;
				mp[r][c] = '*';
				vis1[r][i] = vis2[c][i] = vis3[r / 2 * 2 + c / 2][i] = false;
			}
		}
	}
	else 
		search(cur + 1);
}

void init() {
	memset(vis1, false, sizeof(vis1));
	memset(vis2, false, sizeof(vis2));
	memset(vis3, false, sizeof(vis3));
	found = false;
}

int main() {
	int T;
	scanf("%d", &T);

	while (T--) {
		init();

		for (int i = 0; i < 4; ++i) {
			scanf("%s", mp[i]);
			for (int j = 0; j < 4; ++j)
				if (mp[i][j] != '*') {
					int idx = mp[i][j] - '0';
					vis1[i][idx] = vis2[j][idx] = vis3[i / 2 * 2 + j / 2][idx] = true;
				}
		}

		search(0);

		static int cnt = 0;
		printf("Case #%d:\n", ++cnt);
		for (int i = 0; i < 4; ++i)
			printf("%s\n", mp[i]);
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值