Combinatorics——HDUOJ 1492 - The number of divisors about Humble Numbers(约数个数/约数之和/分解质因数)

原题

  • Problem Description

    A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, … shows the first 20 humble numbers.
    Now given a humble number, please write a program to calculate the number of divisors about this humble number.For examle, 4 is a humble,and it have 3 divisors(1,2,4);12 have 6 divisors.

  • Input

    The input consists of multiple test cases. Each test case consists of one humble number n,and n is in the range of 64-bits signed integer. Input is terminated by a value of zero for n.

  • Output

    For each test case, output its divisor number, one line per case.

  • Sample Input

    4
    12
    0

  • Sample Output

    3
    6

解题思路:

题目大致意思就是:丑数有且只有四种因子:2,3,5,7。给你一个丑数,算出这个丑数有多少种约数。

  • 题目既然已经说明了丑数分解之后最小的数为2、3、5、7,那么直接通过循环除法来得出可以分解出a个2,b个3,c个5,d个7.
  • 最后通过(1+a)×(1+b)×(1+c)×(1+d)得出约数的个数
代码:
#include <stdio.h>
int main()
{
    long long n;      short a, b, c, d; 
    while (scanf("%lld",&n)!=EOF&&n!=0)
    {
        a = b = c = d = 1;
        while (n != 1 && n % 2 == 0){
            a++; n /= 2;
        }
        while (n != 1 && n % 3 == 0){
            b++; n /= 3;
        }
        while (n != 1 && n % 5 == 0){
            c++; n /= 5;
        }
        while (n != 1 && n % 7 == 0){
            d++; n /= 7;
        }
        printf("%d\n", a*b*c*d);
    }
}

总结:

  • 求一个数的约数的个数:
    • 先分解质因数,得出每个因数对应出现的个数a、b……:例如12 = 2^2 × 3^1>>>a=2,b=1
    • 约数的个数等于(1+a)×(1+b):例如f(12) = (1+2)×(1+1)= 6
  • 求一个数的所有约数之和:
    • 先分解质因数,得X=a1^k1 × a2^k2× ……..× an^kn :例如12 = 2^2 × 3^1>>>a1=2,k1=2,a2=3,k2=1
    • 约数的之和等于(1+a1+a1^2…a1^k1)×(1+a2+a2^2…a2^k2)×…..×(1+an+an^2…an^kn):例如f(12) = (1+2+4)×(1+3)= 28
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值