集训队专题(9)1006 MooFest

MooFest

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 32   Accepted Submission(s) : 16
Problem Description
Every year, Farmer John's N (1 <= N <= 20,000) cows attend "MooFest",a social gathering of cows from around the world. MooFest involves a variety of events including haybale stacking, fence jumping, pin the tail on the farmer, and of course, mooing. When the cows all stand in line for a particular event, they moo so loudly that the roar is practically deafening. After participating in this event year after year, some of the cows have in fact lost a bit of their hearing. 

Each cow i has an associated "hearing" threshold v(i) (in the range 1..20,000). If a cow moos to cow i, she must use a volume of at least v(i) times the distance between the two cows in order to be heard by cow i. If two cows i and j wish to converse, they must speak at a volume level equal to the distance between them times max(v(i),v(j)). 

Suppose each of the N cows is standing in a straight line (each cow at some unique x coordinate in the range 1..20,000), and every pair of cows is carrying on a conversation using the smallest possible volume. 

Compute the sum of all the volumes produced by all N(N-1)/2 pairs of mooing cows. 
 

Input
* Line 1: A single integer, N <br> <br>* Lines 2..N+1: Two integers: the volume threshold and x coordinate for a cow. Line 2 represents the first cow; line 3 represents the second cow; and so on. No two cows will stand at the same location. <br>
 

Output
* Line 1: A single line with a single integer that is the sum of all the volumes of the conversing cows. <br>
 

Sample Input
  
  
4 3 1 2 5 2 6 4 3
 

Sample Output
  
  
57
 

Source
PKU
 

此题算是树状数组中一道相当复杂的题目,因为此题并不是单纯的一个树状数组,也不是单纯的二维树状数组,而是需要我们建立两个树状数组,题意:一群牛去过节日,每只牛的听力程度是v[i],每两只牛交流所需要消耗的能量是dis(i,j) * max(v[i], v[j]), 问我们所有牛交流所消耗的能量总和(一共n*(n-1)/2种)。设计到求和的问题,一般来讲用树状数组是比较好的选择,但是这里我们必须借助到两个树状数组,一个用于存距离,一个用于存听力,我们可以先对这群牛按照听力大小进行排序,然后排在某一只牛前面的都是以这只牛的听力进行交流,所以和它排在前面的牛交流就是它和排在它前面的牛的距离之和乘上它的声音,如此一来,我们就可以用两个树状数组进行解答。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define LL __int64
using namespace std;
const int maxn = 20005;
struct Node
{
	LL v,x;
	bool operator < (const Node &a)const
	{
		return v < a.v;
	}
}node[maxn];
LL num[2][maxn];
LL Lowbit(int pos)
{
	return pos&(-pos);
}
LL sum(int pos, int d)
{
	LL ans = 0;
	while(pos > 0)
	{
		ans += num[d][pos];
		pos -= Lowbit(pos);
	}
	return ans;
}
void update(int pos,LL v,int d)
{
	while(pos < maxn)
	{
		num[d][pos] += v;
		pos += Lowbit(pos);
	}
}
int main()
{
	int n;
	scanf("%d",&n);
	memset(num,0,sizeof(num));
	for(int i=1; i<=n; i++)
		scanf("%I64d%I64d",&node[i].v,&node[i].x);
	sort(node+1,node+1+n);
	LL ans = 0;
	for(int i=1; i<=n; i++)
	{
		LL a = sum(node[i].x,0),b = sum(node[i].x,1);
		ans += (node[i].x*a - b + sum(maxn,1) - b - (i-1-a)*node[i].x)*node[i].v;
		update(node[i].x,1,0);
		update(node[i].x,node[i].x,1);
	}
	printf("%I64d\n",ans);
	return 0;
}


  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值