[ PAT-A ] 1031 Hello World for U (C++)

题目描述

Given any string of N (>=5) characters, you are asked to form the characters into the shape of U. For example, “helloworld” can be printed as:
h    d
e     l
l      r
lowo
That is, the characters must be printed in the original order, starting top-down from the left vertical line with n~1~ characters, then left to right along the bottom line with n~2~ characters, and finally bottom-up along the vertical line with n~3~ characters. And more, we would like U to be as squared as possible – that is, it must be satisfied that n~1~ = n~3~ = max { k| k <= n~2~ for all 3 <= n~2~ <= N } with n~1~+ n~2~ + n~3~ - 2 = N.

Input Specification:
Each input file contains one test case. Each case contains one string with no less than 5 and no more than 80 characters in a line. The string contains no white space.

Output Specification:
For each test case, print the input string in the shape of U as specified in the description.

Sample Input:
helloworld!

Sample Output:
h       !
e      d
l        l
lowor


解题思路

题目大意
给定一串字符,将其按U字形输出
思路
输出格式问题.假设字符长度为n,则
输出U字形的高度为(n+2)/3,宽度为(n+2)/3+(n+2)%3;


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<cstring>
//zhicheng
//August 13,2018
const int maxn=85;
char a[maxn];
int main()
{
    scanf("%s",a);
    int len=strlen(a);
    int h=(len+2)/3,w=(len+2)/3+(len+2)%3,i=0,j=len-1;
    for(int k=1;k<h;k++)
    {
        printf("%c",a[i++]);
        for(int v=1;v<=w-2;v++) printf(" ");
        printf("%c",a[j--]);
        printf("\n");
    }
    for(;i<=j;)printf("%c",a[i++]);
    printf("\n");
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值