[ PAT-A ] 1039 Course List for Student (C++)

题目描述

Zhejiang University has 40000 students and provides 2500 courses. Now given the student name lists of all the courses, you are supposed to output the registered course list for each student who comes for a query.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=40000), the number of students who look for their course lists, and K (<=2500), the total number of courses. Then the student name lists are given for the courses (numbered from 1 to K) in the following format: for each course i, first the course index i and the number of registered students N~i~ (<= 200) are given in a line. Then in the next line, N~i~ student names are given. A student name consists of 3 capital English letters plus a one-digit number. Finally the last line contains the N names of students who come for a query. All the names and numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in N lines. Each line corresponds to one student, in the following format: first print the student’s name, then the total number of registered courses of that student, and finally the indices of the courses in increasing order. The query results must be printed in the same order as input. All the data in a line must be separated by a space, with no extra space at the end of the line.

Sample Input:

11 5
4 7
BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
1 4
ANN0 BOB5 JAY9 LOR6
2 7
ANN0 BOB5 FRA8 JAY9 JOE4 KAT3 LOR6
3 1
BOB5
5 9
AMY7 ANN0 BOB5 DON2 FRA8 JAY9 KAT3 LOR6 ZOE1
ZOE1 ANN0 BOB5 JOE4 JAY9 FRA8 DON2 AMY7 KAT3 LOR6 NON9

Sample Output:

ZOE1 2 4 5
ANN0 3 1 2 5
BOB5 5 1 2 3 4 5
JOE4 1 2
JAY9 4 1 2 4 5
FRA8 3 2 4 5
DON2 2 4 5
AMY7 1 5
KAT3 3 2 4 5
LOR6 4 1 2 4 5
NON9 0


解题思路

题目大意
已知每门课选课学生的名单,现在给定一组学生名单,输出他们的所选课程的情况(所选课程总数+哪些课程(从小到大排序))
思路
因为时间限制在200ms之内,只能牺牲空间节约时间,且不能用string,cin,cout,所以采用哈希表处理将姓名字符串对应到整型


代码设计
//AC代码
//zhicheng
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
// zhicheng
// August 21,2018
const int maxn=26*26*26*10+10;
vector<int> ma[maxn];// 记载每位学生选课情况
int getid(char* name)
{// HASH表
    int id=0;
    for(int i=0;i<3;i++) id=26*id+(name[i]-'A');
    id=id*10+(name[3]-'0');
    return id;
}
int main()
{
    freopen("1.in","r",stdin);
    int numb,cour;char name[4];
    for(scanf("%d %d",&numb,&cour);cour;cour--)
    {// 获取学生选课情况
        int id,stu_num;
        for(scanf("%d %d",&id,&stu_num);stu_num;stu_num--)
        {
            scanf("%s",name);
            ma[getid(name)].push_back(id);
        }
    }
    // 输出需要查询的学生的选课情况
    for(int i=0;i<numb;i++)
    {
        scanf("%s",name);printf("%s",name);
        int na=getid(name),len=ma[na].size();
        if(!len){printf(" 0\n");continue;}
        printf(" %d",len);
        sort(ma[na].begin(),ma[na].end());
        for(int i=0;i<len;i++) printf(" %d",ma[na][i]);
        printf("\n"); 
    }
    return 0;
}


有关PAT (Basic Level) 的更多内容可以关注 ——> PAT-B题解


有关PAT (Advanced Level) 的更多内容可以关注 ——> PAT-A题解

铺子日常更新,如有错误请指正
传送门:代码链接 PTA题目链接 PAT-A题解

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值