B - Gary's Calculato

B - Gary's Calculator
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Gary has finally decided to find a calculator to avoid making simple calculational mistakes in his math exam. Unable to find a suitable calculator in the market with enough precision, Gary has designed a high-precision calculator himself. Can you help him to write the necessary program that will make his design possible? 
For simplicity, you only need to consider two kinds of calculations in your program: addition and multiplication. It is guaranteed that all input numbers to the calculator are non-negative and without leading zeroes. 
 

Input

There are multiple test cases in the input file. Each test case starts with one positive integer N (N < 20), followed by a line containing N strings, describing the expression which Gary's calculator should evaluate. Each of the N strings might be a string representing a non-negative integer, a "*", or a "+". No integer in the input will exceed 10  9
Input ends with End-of-File. 
 

Output

For each test case, please output one single integer (with no leading zeros), the answer to Gary's expression. If Gary's expression is invalid, output "Invalid Expression!" instead. Please use the format indicated in the sample output. 
 

Sample Input

     
     
3 100 + 600 3 20 * 4 2 + 500 5 20 + 300 * 20
 

Sample Output

     
     
Case 1: 700 Case 2: 80 Case 3: Invalid Expression! Case 4: 6020



题目会先给出你一个数N,代表接下来的字段数,每一个字段可能是一个数字(没有前导零,非负),也可能是一个运算符(+,*),然后让你输出这个算式的结果。如果算式的格式错误就输出    Invalid Expression! 


思路,从头开始往后扫, 在判断是否格式错误的前提下判断数字与符号的相对位置,来将所有的数字分成很多个相乘的块,然后边判断边操作就行。


注意要使用高精度,还有就是初始化的问题。

因为一开始以为数组定义后内部会全部初始化为零,结果WA了很多次,加了初始化后直接A掉。


#include"iostream"
#include"cstring"
#include"cstdio"
#include"string"

using namespace std;

char snum[25][105];
int ans[1005];
int res[1005];
int n;

void cheng(char *s)
{
    int num1[1005];
    memset(num1,0,sizeof(num1));
    int len = strlen(s);
    for(int i = len-1,j = 0;i >= 0;i--,j++)
    {
        num1[j] = s[i] - '0';
    }

    int num2[2005];
    memset(num2,0,sizeof(num2));
    for(int i = 0;i < 500;i++)
    {
        int k = i;
        for(int j = 0;j < 1005;j++)
        {
            num2[k++] += ans[i]*num1[j];
        }
    }
    for(int i = 0;i < 1005;i++)
    {
        if(num2[i] / 10 > 0)
        {
            ans[i] = num2[i] %10;
            num2[i+1] += num2[i]/10;
        }
        else
        {
            ans[i] = num2[i];
        }
    }
}

void add()
{
    for(int i = 0;i < 1004;i++)
    {
        res[i] += ans[i];
    }
    for(int i = 0;i < 1004;i++)
    {
        if(res[i]/10 > 0)
        {
            res[i+1]+=res[i]/10;
            res[i] %= 10;
        }
    }
}

int main(void)
{
    int cas = 0;
    while(~scanf("%d",&n))
    {
        cas ++;
        memset(ans,0,sizeof(ans));
        memset(res,0,sizeof(res));
        memset(snum,'\0',sizeof(snum));
        for(int i = 0;i < n;i++) scanf("%s",snum[i]);
        if(n%2 == 0)
        {
            printf("Case %d: Invalid Expression!\n",cas);
            continue;
        }
        char now = '+';
        bool flag = false;
        for(int i = 0;i < n;i++)
        {
            if(now == '*' || now == '+')
            {
                if(snum[i][0] == '*' || snum[i][0] == '+')
                {
                    printf("Case %d: Invalid Expression!\n",cas);
                    flag = true;
                    break;
                }
                else
                {
                    if(now == '+')
                    {
                        memset(ans,0,sizeof(ans));
                        int len = strlen(snum[i]);
                        for(int k = len-1,j = 0;k >= 0;k--,j++) ans[j] = snum[i][k] - '0';
                    }
                    else
                    {
                        cheng(snum[i]);
                    }
                    now = 'n';
                }
            }
            else
            {
                if(i == n-1)
                {
                    printf("Case %d: Invalid Expression!\n",cas);
                    flag = true;
                    break;
                }
                if(snum[i][0] != '*' && snum[i][0] != '+')
                {
                    printf("Case %d: Invalid Expression!\n",cas);
                    flag = true;
                    break;
                }
                else
                {
                    if(snum[i][0] == '+')
                    {
                        add();
                        now = '+';
                    }
                    else
                    {
                        now = '*';
                    }
                }
            }
        }
        if(flag) continue;
        add();
        printf("Case %d: ",cas);
        int respos = 1004;
        for(;respos >= 0;respos--) if(res[respos]) break;
        if(respos == -1) printf("0");
        for(;respos >= 0;respos--) printf("%d",res[respos]);
        printf("\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值