hdu 1879 继续畅通工程

133 篇文章 17 订阅
75 篇文章 9 订阅
/************************************************************************/
/* hdu 1879
继续畅通工程


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6017    Accepted Submission(s): 2493




Problem Description
省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。现得到城镇道路统计表,表中列出了任意两城镇间修建道路的费用,以及该道路是否已经修通的状态。现请你编写程序,计算出全省畅通需要的最低成本。




Input
测试输入包含若干测试用例。每个测试用例的第1行给出村庄数目N ( 1< N < 100 );随后的 N(N-1)/2 行对应村庄间道路的成本及修建状态,每行给4个正整数,分别是两个村庄的编号(从1编号到N),此两村庄间道路的成本,以及修建状态:1表示已建,0表示未建。


当N为0时输入结束。




Output
每个测试用例的输出占一行,输出全省畅通需要的最低成本。




Sample Input
3
1 2 1 0
1 3 2 0
2 3 4 0
3
1 2 1 0
1 3 2 0
2 3 4 1
3
1 2 1 0
1 3 2 1
2 3 4 1
0




Sample Output
3
1
0




Author
ZJU




Source
浙大计算机研究生复试上机考试-2008年
*/
/************************************************************************/
//最小生成树
#include "iostream"
#include "stdio.h"
#include "math.h"
#include "vector"
#include "queue"
#include "memory.h"
#include "algorithm"
#include "string"
using namespace std;
#define N 105


int father[N];
int road[N*(N-1)/2+10][3];
int n,m;


int comp(const void *a,const void *b)
{
	return *((int *)a)-*((int *)b);
}


int cha(int x)
{
	while(x!=father[x])
		x=father[x];
	return x;
}


void bing(int a,int b)
{
	father[cha(a)]=cha(b);//notice! not father[a]=cha(b);
}


int main()
{
	int i,j,a,b,v,f;
	while(scanf("%d",&n)!=EOF&&n)
	{
		for(i=1;i<=n;i++)
			father[i]=i;
		m=n*(n-1)/2;
		int cnt=0;
		for (i=0;i<m;i++)
		{
			scanf("%d%d%d%d",&a,&b,&v,&f);
			if(f)
				road[cnt][0]=0;
			else
				road[cnt][0]=v;
			road[cnt][1]=a;
			road[cnt][2]=b;
			cnt++;
		}
		qsort(road,cnt,sizeof(int)*3,comp);
		int num=0;
		int sum=0;
		for(i=0;i<m&&num<n-1;i++)
		{
			a=road[i][1];
			b=road[i][2];
			if(cha(a)!=cha(b))
			{
				bing(a,b);
				sum+=road[i][0];
			}
		}
		printf("%d\n",sum);
	}
}


评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值