A Simple Problem with Integers

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4
Sample Output
4
55
9
15
Hint
The sums may exceed the range of 32-bit integers.


区间更新,用sum记录每个节点的增量,对于某个区间,什么时候用什么时候更新

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<queue>
#include<vector>
using namespace std;
const int MAXN=100000+10;
const int MAXM=1000000+10;
const int inf=0x3f3f3f;
int x[MAXN];
struct node
{
    int left,right;
    long long value;
    long long sum;
} z[3*MAXN];
void build(int i,int left,int right)
{
    z[i].left=left;
    z[i].right=right;
    z[i].sum=0;
    if(left==right)
    {
        z[i].value=x[left];
        return ;
    }
    int mid=(left+right)/2;
    build(i<<1,left,mid);
    build((i<<1)+1,mid+1,right);
    z[i].value=z[i<<1].value+z[(i<<1)+1].value;
}
void update(int i,int left,int right,long long num)
{
    if(z[i].left==left&&z[i].right==right)
    {
        z[i].sum+=num;
        return ;
    }
    z[i].value+=(right-left+1)*num;
    int mid=(z[i].left+z[i].right)/2;
    if(right<=mid)
        update(i<<1,left,right,num);
    else if(left>mid)
        update((i<<1)+1,left,right,num);
    else
    {
        update(i<<1,left,mid,num);
        update((i<<1)+1,mid+1,right,num);
    }
}
long long inquiry(int i,int left,int right)
{
    if(z[i].left==left&&z[i].right==right)
        return z[i].value+(right-left+1)*z[i].sum;
    z[i].value+=(z[i].right-z[i].left+1)*z[i].sum;
    int mid=(z[i].left+z[i].right)/2;
    update(i<<1,z[i].left,mid,z[i].sum);
    update((i<<1)+1,mid+1,z[i].right,z[i].sum);
    z[i].sum=0;
    if(right<=mid)
        return inquiry(i<<1,left,right);
    else if(left>mid)
        return inquiry((i<<1)+1,left,right);
    else
        return inquiry(i<<1,left,mid)+inquiry((i<<1)+1,mid+1,right);
}
int main()
{
    int n,m;
    string s;
    int a,b,c;
    while(~scanf("%d%d",&n,&m))
    {
        for(int i=1; i<=n; i++)
            scanf("%d",&x[i]);
        build(1,1,n);
        while(m--)
        {
            cin>>s;
            if(s=="Q")
            {
                scanf("%d %d",&a,&b);
                printf("%lld\n",inquiry(1,a,b));
            }
            else if(s=="C")
            {
                scanf("%d%d%d",&a,&b,&c);
                update(1,a,b,c);
            }
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值