HUST1010——The Minimum Length(KMP)

Description

There is a string A. The length of A is less than 1,000,000. I rewrite it again and again. Then I got a new string: AAAAAA...... Now I cut it from two different position and get a new string B. Then, give you the string B, can you tell me the length of the shortest possible string A. For example, A="abcdefg". I got abcd  efgabcdefgabcdefgabcdefg.... Then I cut the red part: efgabcdefgabcde as string B. From B, you should find out the shortest A.

Input

Multiply Test Cases. For each line there is a string B which contains only lowercase and uppercase charactors. The length of B is no more than 1,000,000.

Output

For each line, output an integer, as described above.

Sample Input

bcabcab
efgabcdefgabcde

Sample Output

3
7

用KMP求最小循环点。因为KMP是求一段字符中某一段与前段相等的长度,所以与前一段相等长度最大的数,再用总长度减去这个数,就是最小循环点

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 1000005;
char T[MAXN];
int  f[MAXN];

void getFail(char *p,int *f)
{
    int n=strlen(p);
    f[0]=f[1]=0;
    for(int i=1; i<n; ++i)
    {
        int j=f[i];
        while(j && p[i]!=p[j])
            j=f[j];
        if(p[i]==p[j])
            f[i+1]=1+j;
        else
            f[i+1]=0;
    }
}

int main()
{
    while(gets(T))
    {
        getFail(T,f);
        int n=strlen(T);
        printf("%d\n", n-f[n]);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值