hdu3829——Cat VS Dog(最大独立集)

Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child’s like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child’s like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child’s like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

Output
For each case, output a single integer: the maximum number of happy children.

Sample Input
1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1

Sample Output
1
3

Hint
Case 2: Remove D1 and D2, that makes child 1, 2, 3 happy.

对小孩拆点,能建边的条件是两个小孩喜欢的动物和不喜欢的正好矛盾,说明这两个小孩需要作出取舍,接下来最大幸福度就是作出最大限度不用作出取舍的小孩的幸福度,其实就是最大独立集
当然以上都是我口胡的

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
//#include <map>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 1505
#define Mod 10001
using namespace std;
bool vis[MAXN];
int pre[MAXN],n;  //匹配路径;
vector<int> map[MAXN];
string like[MAXN],dislike[MAXN];
int find(int cur)
{
    for(int i=0; i<map[cur].size(); ++i)
    {
        int v=map[cur][i];
        if(!vis[v])
        {
            vis[v] = true;
            if(pre[v] == 0 || find(pre[v]))
            {
                pre[v] = cur;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int m,p;
    while(~scanf("%d%d%d",&n,&m,&p))
    {
        memset(map,0,sizeof(map));
        for(int i=0; i<p; ++i)
        {
            string a,b;
            cin>>a>>b;
            like[i]=a;
            dislike[i]=b;
        }
        for(int i=0; i<p; ++i)
            for(int j=0; j<p; ++j)
            {
                if(like[i]==dislike[j]||dislike[i]==like[j])
                {
                    map[i].push_back(j);
                    map[j].push_back(i);
                }
            }
        int ans=0;
        memset(pre,0,sizeof(pre));
        for(int i=0; i<p; ++i)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                ans++;
        }
        printf("%d\n",p-ans/2);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值