poj1094——Sorting It All Out(拓扑排序)

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.
Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character “<” and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.
Output

For each problem instance, output consists of one line. This line should be one of the following three:

Sorted sequence determined after xxx relations: yyy…y.
Sorted sequence cannot be determined.
Inconsistency found after xxx relations.

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy…y is the sorted, ascending sequence.
Sample Input

4 6
A< B
A< C
B< C
C< D
B< D
A< B
3 2
A< B
B< A
26 1
A< Z
0 0
Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.

题意是给出一些比较关系,求给出这些关系的过程中1 )能否有一个确定的排序,有的话给出关系的个数并求出这个排序的序列;2)是否成环;3)不能确定
只有一个确定排序的拓扑序列的性质应该是,只有一个入度为0的节点,去掉此节点后,剩下的还是只有一个入度为0的点。按照这个性质模拟就行了。

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <cmath>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAXN 105
#define Mod 10001
using namespace std;
int n,m,c;
int map[30][30],temp[30],indegree[30],q[30];
int topsort(int n)
{
    int m,pos,flag=1;
    c=0;
    for(int i=1; i<=n; ++i)
        temp[i]=indegree[i];
    for(int i=1; i<=n; ++i)
    {
        m=0;
        for(int j=1; j<=n; ++j)
            if(temp[j]==0) //选择一个入度为0的点,即可能为起点
            {
                m++;
                pos=j;
            }
        if(m==0)
            return 0; //有环
        if(m>1)
            flag=-1;  //还不确定
        q[c++]=pos; //该起点入栈
        temp[pos]=-1;
        for(int j=1;j<=n;++j)
            if(map[pos][j]) //把起点去掉后,相连的点要有处理
                temp[j]--;
    }
    return flag;
}
int main()
{
    char op[10];
    while(~scanf("%d%d",&n,&m))
    {
        getchar();
        if(n==0&&m==0)
            break;
        memset(indegree,0,sizeof(indegree));
        memset(map,0,sizeof(map));
        int s=-1,flag=0;
        for(int i=1; i<=m; ++i)
        {
            gets(op);
            if(s==0||s==1)
                continue;
            int x=op[0]-'A'+1;
            int y=op[2]-'A'+1;
            map[x][y]=1;
            indegree[y]++;
            s=topsort(n);
            if(s==0)
            {
                printf("Inconsistency found after %d relations.\n",i);
                flag=1;
            }
            if(s==1)
            {
                printf("Sorted sequence determined after %d relations: ",i);
                for(int j=0;j<c;++j)
                    printf("%c",q[j]+'A'-1);
                printf(".\n");
                flag=1;
            }
        }
        if(!flag)
            printf("Sorted sequence cannot be determined.\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值