poj-1035 Spell checker

3 篇文章 0 订阅

Description

You, as a member of a development team for a new spell checking program, are to write a module that will check the correctness of given words using a known dictionary of all correct words in all their forms.
If the word is absent in the dictionary then it can be replaced by correct words (from the dictionary) that can be obtained by one of the following operations:
?deleting of one letter from the word;
?replacing of one letter in the word with an arbitrary letter;
?inserting of one arbitrary letter into the word.
Your task is to write the program that will find all possible replacements from the dictionary for every given word.

Input

The first part of the input file contains all words from the dictionary. Each word occupies its own line. This part is finished by the single character '#' on a separate line. All words are different. There will be at most 10000 words in the dictionary.
The next part of the file contains all words that are to be checked. Each word occupies its own line. This part is also finished by the single character '#' on a separate line. There will be at most 50 words that are to be checked.
All words in the input file (words from the dictionary and words to be checked) consist only of small alphabetic characters and each one contains 15 characters at most.

Output

Write to the output file exactly one line for every checked word in the order of their appearance in the second part of the input file. If the word is correct (i.e. it exists in the dictionary) write the message: " is correct". If the word is not correct then write this word first, then write the character ':' (colon), and after a single space write all its possible replacements, separated by spaces. The replacements should be written in the order of their appearance in the dictionary (in the first part of the input file). If there are no replacements for this word then the line feed should immediately follow the colon.

Sample Input

i
is
has
have
be
my
more
contest
me
too
if
award
#
me
aware
m
contest
hav
oo
or
i
fi
mre
#

Sample Output

me is correct
aware: award
m: i my me
contest is correct
hav: has have
oo: too
or:
i is correct
fi: i
mre: more me

     题意:先输入一组数据作为字典里的单词以#结束,在输入一组数据为需要与字典里核对的单词,如果这个单词与字典里的完全相符,那么输出** is correct,若不同且差一个字符那么输出**: 之后输出相差一个字符的字典里的单词。

    该题简单易懂,不要怕超时直接暴力找就行了。注意输出格式。

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define INF 0x3f3f3f3f
#include<cmath>
using namespace std;

char dic[100003][20],str[55];

int main()
{
    int i=-1,j=-1,k,len1,len2;
    int maxl,minl;
    while (scanf("%s",dic[++i]),dic[i][0]!='#');
    while (scanf("%s",str),str[0]!='#')
    {
        int flag1=0,flag2;
        for (k=0; k<i; k++)
        {
            if(strcmp(str,dic[k])==0)
            {
                printf("%s is correct\n",str);
                flag1=2;
                break;
            }
        }
        if(flag1==2) continue;
        printf("%s:",str);
        for (k=0; k<i; k++)
        {
            flag2=0;
            len1=strlen(dic[k]);
            len2=strlen(str);

            if(abs(len1-len2)>1)
                continue;
            if(len1-len2==1)
            {
                int x=0,y=0;
                while(x<len1)
                {
                    if(dic[k][x]!=str[y])
                    {
                        x++;
                        flag2++;
                    }
                    else
                    {
                        x++;
                        y++;
                    }
                }
            }
            else if(len1-len2==-1)
            {
                int x=0,y=0;
                while(y<len2)
                {
                    if(dic[k][x]!=str[y])
                    {
                        y++;
                        flag2++;
                    }
                    else
                    {
                        x++;
                        y++;
                    }
                }
            }
            else if(len1-len2==0)
            {
                int x=0,y=0;
                while(x<len1)
                {
                    if(dic[k][x]!=str[y])
                    {
                        flag2++;x++;y++;
                    }
                    else
                    {
                        x++;
                        y++;
                    }
                }
            }
            if(flag2==1) printf(" %s",dic[k]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值