POJ 2135 Rank List

5 篇文章 0 订阅

Description
Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?
Input
The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other.

In (N+2)-th line, you’ll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam.
Output
The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.
Sample Input
3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming
Sample Output
1
2

题意:
先输入班级的学生人数、名字和考试次数,在输入每场考试每位同学的分数,输出截至当前考试 Li Ming在班里的排名(注意:每次考试的分数累加)
可用map来存储同学的得分情况

#include <iostream>
#include <string>
#include<cstdio>
#include<map>
using namespace std;
int main()
{
    int N,n,i,score,max,place;
    string name;
    map <string,int> mymap;
    map <string,int> ::iterator it;//声明一个迭代器
    cin>>N;
    getchar();//读入换行
    for(i=0;i<N;i++)
    {
        getline(cin,name);
    }
    cin>>n;
    while(n>0)
    {
        max=0;
        place=1;//初始名次定为1
        for(i=0;i<N;i++)
        {
            cin>>score;
            getchar();//读入空格
            getline(cin,name);
            mymap[name]+=score;//分数累加
        }
        it=mymap.find("Li Ming");//迭代器指向Li Ming
        max=it->second;//将Li Ming的成绩设为最大
        for(it=mymap.begin();it!=mymap.end();++it)//循环所有同学的成绩
        {
            if(it->second>max)
                place++;//若成绩大于Li Ming,则Li Ming的排名加1
        }
        cout<<place<<endl;
        n--;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值