Good Numbers (数位DP)

If we sum up every digit of a number and the result can be exactly divided by 10, we say this number is a good number.
You are required to count the number of good numbers in the range from A to B, inclusive.

Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
Each test case comes with a single line with two numbers A and B (0 <= A <= B <= 10 18).
Output
For test case X, output "Case #X: " first, then output the number of good numbers in a single line.
Sample Input
2
1 10
1 20
Sample Output
Case #1: 0
Case #2: 1

        
  
Hint
The answer maybe very large, we recommend you to use long long instead of int.

        
 

题意:

求a,b之间的数的每个数位上的和能被10整除的个数;

代码一:

从0开始暴力跑一遍会发现每10个数字会有一个成立,所以我们求0到a-1的个数为num1,0到b的个数为num2

最后结果为sum1-sum2

#include<stdio.h>
#include<string.h>
using namespace std;
typedef long long ll;
int Is(ll x){  
	int sum=0;
	while(x){
		sum+=x%10;
		x/=10;
	}
	if(sum%10==0) return 1;
	else return 0;
}
int main(){
	int T,k=0;
	scanf("%d",&T);
	while(T--){
		ll a,b,num1,num2,i;
		scanf("%lld%lld",&a,&b);
		num1=num2=0;
		a--;
		num1=a/10;
		for(i=a/10*10;i<=a;i++)
		   if(Is(i)) num1++;
		num2=b/10;
		for(i=b/10*10;i<=b;i++)
		    if(Is(i)) num2++;
		printf("Case #%d: %lld\n",++k,num2-num1);
	}
	return 0;
}

代码2(数位dp):

#include<stdio.h>
#include<string.h>
using namespace std;
typedef long long ll;
int a[20];
ll dp[20][10];  //dp[i][j] 表示 第i位数字对10取余得到j的个数 
ll Dfs(int pos,int sta,bool limit){//pos:当前位置 sta:余数 limit:限制条件 
	if(pos<0) return sta==0;
	if(!limit&&dp[pos][sta]!=-1) return dp[pos][sta];
	ll cnt=0,i;
	int up=limit?a[pos]:9;
	for(i=0;i<=up;i++)
		cnt+=Dfs(pos-1,(i+sta)%10,limit&&(i==a[pos]));
	if(!limit) dp[pos][sta]=cnt;
	return cnt;
}
ll solve(ll x){
	int pos=0;
	while(x){
		a[pos++]=x%10;
		x/=10;
	}
	return Dfs(pos-1,0,true);
}
int main(){
	int T;
	scanf("%d",&T);
	memset(dp,-1,sizeof(dp));
	int k=0;
	while(T--){
		ll l,r;
		scanf("%lld%lld",&l,&r);
		printf("Case #%d: %lld\n",++k,solve(r)-solve(l-1));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值