UVa10110 Light, more light

 

Light,more light

The Problem

There is man named "mabu" for switching on-off light in our University.He switches on-off the lights in a corridor. Every bulb has its own toggle switch. That is, if it is pressed then the bulb turns on. Another press will turn it off. To save power consumption(or may be he is mad or something else) he does a peculiar thing. If ina corridor there is `n' bulbs, he walks along the corridor back and forth`n' times and in i'th walk he toggles only the switches whose serial is divisable by i. He does not press any switch when coming back to his initial position.A i'th walk is defined as going down the corridor (while doing the peculiar thing) and coming back again.

Now you have to determine what is the final condition of the last bulb. Is it on or off?
 

The Input

The input will be an integer indicating the n'th bulb in a corridor. Which is less thenor equals 2^32-1. A zero indicates the end of input. You should not processthis input.

The Output

Output " yes" if the light is on otherwise " no" , in a single line.

SampleInput

3
6241
8191
0

SampleOutput

no
yes
no

Sadi Khan
Suman Mahbub
01-04-2001


这题的大意是有一个走廊,里面排列着许多灯,这些灯的开关取决于他们编号的因子编号的开关,这些灯开始时都是暗的,现给出一个灯号,要求求出当一个人从第一盏灯开到第n盏灯时,该灯的开关。由于当该灯号的因子为偶数是结果是暗的,否则为亮的,又因为仅有完全平方数的因子个数为奇数,所以只要判断是否为完全平方数即可。

#include <iostream>
#include <cmath>
using namespace std;

int main() {
	long long n;
	long long i;
	while (cin >> n) {
		if (n == 0)
			break;
		i = (int)sqrt(n);
		if (i == sqrt(n))
			cout << "yes" << endl;
		else
			cout << "no" << endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值