PAT A1147 2019.08.12 【层序完全二叉树性质建树 堆 后序遍历】

1147 Heaps (30 分)

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M (≤ 100), the number of trees to be tested; and N (1 < N ≤ 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10

思路分析

2019.09.03重做后更新

层序完全二叉树性质建树

完全二叉树性质判堆

最后后序遍历(输出格式控制的输出次数time定义为其他,若定义为time则提交时会发生编译错误)

也可以不建树直接做

但是后序遍历需要想一想,就直接建树做了

另外判断堆的代码最好写到主函数里面,写成函数不好控制

#include<cstdio>
#include<iostream>
#include<vector>
#define maxHeap 1
#define minHeap 2
#define notHeap 3
using namespace std;
int flag;
int m,n;
int t=0;

typedef struct NODE{
	int data;
	struct NODE *left;
	struct NODE *right;
}NODE;

void postorder(NODE *root)
{
	if(root==NULL)return;
	postorder(root->left);
	postorder(root->right);
	cout<<root->data;t++;
	if(t!=n)cout<<" ";
}

int main()
{
	cin>>m>>n;
	for(int j=0;j<m;j++)
	{
		vector<NODE*>node;
		for(int i=0;i<n;i++)
		{
			NODE *newNode = new NODE;
			newNode->left=NULL;
			newNode->right=NULL;
			cin>>newNode->data;
			node.push_back(newNode);
		}
		for(int i=0;i<n;i++)
		{
			if((2*i+1)<n)node[i]->left=node[2*i+1];
			if((2*i+2)<n)node[i]->right=node[2*i+2];
		}
		NODE *root=node[0];
		t=0;
		
		if(root->data>root->left->data)flag=maxHeap;
		if(root->data<root->left->data)flag=minHeap;
		if(flag==maxHeap)
		{
			for(int i=0;i<n;i++)
			{
				if((2*i+1)<n)if(node[i]->data<node[2*i+1]->data)flag=notHeap;
				if((2*i+2)<n)if(node[i]->data<node[2*i+2]->data)flag=notHeap;
			}
		}
		else if(flag==minHeap)
		{
			for(int i=0;i<n;i++)
			{
				if((2*i+1)<n)if(node[i]->data>node[2*i+1]->data)flag=notHeap;
				if((2*i+2)<n)if(node[i]->data>node[2*i+2]->data)flag=notHeap;
			}
			
		}
		
		if(flag==maxHeap)cout<<"Max Heap"<<endl;
		if(flag==minHeap)cout<<"Min Heap"<<endl;
		if(flag==notHeap)cout<<"Not Heap"<<endl;
		postorder(root);cout<<endl;		
	}	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
1. 创建二叉树: 二叉树是一种树形结构,其中每个节点最多有两个子节点,我们可以通过递归的方式来创建一个二叉树。具体步骤如下: 首先,我们需要定义二叉树节点的结构体: ``` struct TreeNode { int val; TreeNode* left; TreeNode* right; TreeNode(int x) : val(x), left(NULL), right(NULL) {} }; ``` 然后,我们可以通过递归方式创建二叉树,示例代码如下: ``` TreeNode* createTree() { int val; cin >> val; // 输入节点的值 if (val == -1) { // 如果值为-1,表示该节点为空 return NULL; } TreeNode* root = new TreeNode(val); root->left = createTree(); // 递归创建左子树 root->right = createTree(); // 递归创建右子树 return root; } ``` 2. 先序遍历二叉树: 先序遍历是指先访问节点本身,再遍历其左子树和右子树。示例代码如下: ``` void preorderTraversal(TreeNode* root) { if (root == NULL) { return; } cout << root->val << " "; // 访问节点本身 preorderTraversal(root->left); // 遍历左子树 preorderTraversal(root->right); // 遍历右子树 } ``` 3. 中序遍历二叉树1: 中序遍历是指先遍历左子树,再访问节点本身,最后遍历右子树。示例代码如下: ``` void inorderTraversal1(TreeNode* root) { if (root == NULL) { return; } inorderTraversal1(root->left); // 遍历左子树 cout << root->val << " "; // 访问节点本身 inorderTraversal1(root->right); // 遍历右子树 } ``` 4. 中序遍历二叉树2: 与中序遍历1不同,这里给出一种非递归的中序遍历方法,需要使用到栈。示例代码如下: ``` void inorderTraversal2(TreeNode* root) { stack<TreeNode*> st; TreeNode* p = root; while (p != NULL || !st.empty()) { while (p != NULL) { st.push(p); p = p->left; } p = st.top(); st.pop(); cout << p->val << " "; p = p->right; } } ``` 5. 后序遍历二叉树: 后序遍历是指先遍历左子树,再遍历右子树,最后访问节点本身。示例代码如下: ``` void postorderTraversal(TreeNode* root) { if (root == NULL) { return; } postorderTraversal(root->left); // 遍历左子树 postorderTraversal(root->right); // 遍历右子树 cout << root->val << " "; // 访问节点本身 } ``` 6. 层序遍历二叉树: 层序遍历是指按照从上到下、从左到右的顺序遍历每个节点。需要使用到队列。示例代码如下: ``` void levelOrderTraversal(TreeNode* root) { if (root == NULL) { return; } queue<TreeNode*> q; q.push(root); while (!q.empty()) { TreeNode* node = q.front(); q.pop(); cout << node->val << " "; if (node->left != NULL) { q.push(node->left); } if (node->right != NULL) { q.push(node->right); } } } ``` 7. 求二叉树的深度: 二叉树的深度是指从根节点到最远叶子节点的最长路径上的节点数。可以使用递归方式求解。示例代码如下: ``` int maxDepth(TreeNode* root) { if (root == NULL) { return 0; } int leftDepth = maxDepth(root->left); int rightDepth = maxDepth(root->right); return max(leftDepth, rightDepth) + 1; } ``` 8. 退出

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值