HDU 2577 How to Type (dp,思维)

How to Type

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7130 Accepted Submission(s): 3222

Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.

Sample Input
3
Pirates
HDUacm
HDUACM

Sample Output
8
8
8

Hint

The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8.
The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8
The string “HDUACM”, can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8

Author
Dellenge

Source
HDU 2009-5 Programming Contest

题意:
给定一串字母,问最少需要按多少次键盘将这些字母打印到屏幕上,键盘最开始的时候是小写锁定的,最后也要回归到小写锁定。

分析:
在小(大)写锁定下输入小(大)写字母肯定不需要进行考虑了,关键就是在小(大)写锁定下输入大(小)写字母,如果连续的只有一个的话,就用Shift键只需要多按一次,如果两个或者两个以上的话,就转换大小写锁定。
用 dp,贪心思想去写 相比模拟去写会简单很多。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
int dpp[120],dpd[120];
char str[120];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",str+1);
        int i;
        dpp[0]=0;//小写
        dpd[0]=1;//大写
        for(i=1;str[i];i++)
        {
            if(str[i]>='a'&&str[i]<='z')
            {
                dpp[i]=min(dpp[i-1]+1,dpd[i-1]+2);//若灯亮,则直接按字母;若灯灭,则按字母再开灯  
                dpd[i]=min(dpp[i-1]+2,dpd[i-1]+2);//若灯亮,则要先按字母再关灯;若灯灭,则按shift+字母  
            }
            else if(str[i]>='A'&&str[i]<='Z')
            {
                dpp[i]=min(dpp[i-1]+2,dpd[i-1]+2);//若灯亮,则要先关灯再按字母;若灯灭,则字母  
                dpd[i]=min(dpp[i-1]+2,dpd[i-1]+1);//若灯亮,按字母;若灯灭,则按shift+字母  
            }
        }
        printf("%d\n",min(dpp[i-1],dpd[i-1]+1));//最后要关灯,dpb要+1 
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值