hdoj 5240 Exam

Exam

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1034    Accepted Submission(s): 514


Problem Description
As this term is going to end, DRD needs to prepare for his final exams.

DRD has n exams. They are all hard, but their difficulties are different. DRD will spend at least ri hours on the i -th course before its exam starts, or he will fail it. The i -th course's exam will take place ei hours later from now, and it will last for li hours. When DRD takes an exam, he must devote himself to this exam and cannot (p)review any courses. Note that DRD can review for discontinuous time.

So he wonder whether he can pass all of his courses.

No two exams will collide.
 

Input
First line: an positive integer T20 indicating the number of test cases.
There are T cases following. In each case, the first line contains an positive integer n105 , and n lines follow. In each of these lines, there are 3 integers ri,ei,li , where 0ri,ei,li109 .

 

Output
For each test case: output ''Case #x: ans'' (without quotes), where x is the number of test cases, and ans is ''YES'' (without quotes) if DRD can pass all the courses, and otherwise ''NO'' (without quotes).

 

Sample Input
  
  
2 3 3 2 2 5 100 2 7 1000 2 3 3 10 2 5 100 2 7 1000 2
 

Sample Output
  
  
Case #1: NO Case #2: YES

 

题意:一个人有  n  门课要考,每一门课给出复习所必须花费的时间  r  ,这门课考试距现在所剩的时间  e  ,考这门课时所用的时间  l  。问这个人是否能通过全部的考试。


思路:现对考试距现在所剩的时间  e  从小到大进行排序,如果  e  相等,则将  l  进行从小到大排序。然后对复习时间与考试时间进行模拟。


代码:


#include<stdio.h>
#include<algorithm>
using namespace std;
struct record
{
	int r,e,l;
}num[100010];
bool cmp(record a,record b)
{
	return a.e<b.e;
}
int main()
{
	int T,n;
	int i,k=1;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		int f=0;
		for(i=0;i<n;i++)
		{
			scanf("%d%d%d",&num[i].r,&num[i].e,&num[i].l); 
		    if(num[i].r>num[i].e)
		    {
		    	f=1;
		    }
		}
		if(f==1)
		{
			printf("Case #%d: NO\n",k++);
			continue;
		}
		sort(num,num+n,cmp);
		int sum=0;
		for(i=1;i<n;i++)
		{
			sum+=num[i-1].r+num[i-1].l;
			if(num[i].e<num[i].r+sum)
			{
				f=1;
				break;
			}
		}
		if(f==1)
		printf("Case #%d: NO\n",k++);
		else
		printf("Case #%d: YES\n",k++);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值